How to manually set a referrer-URL

More
3 years 9 months ago #99950 by Johan01
Johan01 created the topic: How to manually set a referrer-URL
Hi all,

I´m running a psychological experiment via LimeSurvey (LS). Since I´m recruiting participants in diverse online forums I want to keep track of which participant is coming from which forum. Hence, I activated the referrer-URL option in the general settings of my survey.But apparently, this is not working. I only get a refurl saved if I use the test survey-function inside LS. In all other cases the refurl field is just blank.
I also tried to manually enter the refurl with something like "?refurl=forum1" at the end of the survey link to identify participants but that did not work out as well.

I would be very grateful if somebody could help me out with that.

Cheers,
J.

à chacun son goût

Please Log in to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #99968 by DenisChenu
DenisChenu replied the topic: How to manually set a referrer-URL
Hi,

Think best is to use PASSTHRU settings.

You see this in survey settings/Panel integration
The youn can prefill a Question with a param from url. Choose a text questioon type and set 'allways hide this question' to yes.

Denis
manual.limesurvey.org/Creating_a_new_sur....28URL_parameters.29

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 years 9 months ago by DenisChenu.
The following user(s) said Thank You: Johan01

Please Log in to join the conversation.

More
3 years 9 months ago #99977 by Johan01
Johan01 replied the topic: How to manually set a referrer-URL
Got it! Thanks a lot!

à chacun son goût

Please Log in to join the conversation.

More
3 months 5 days ago #151090 by taunus
taunus replied the topic: How to manually set a referrer-URL
Hey guys,

sorry that if have to pick this up again. I am trying to do the same thing as Johan and include IDs for two different groups of respondents, but my panel integration parameters dont work properly. I dont really get the combination of the passthru command and the parameter.

Currently my survey URL looks like this:

.../index.php/351982?lang=de&id=123

Now when I try to transfer this ID into a question via Panel Integration, I add a parameter "id" and link it to a short text question (which is hidden in the survey). However, this does not work out and I do not see any ID in the recorded answers.

What am I doing wrong? Unfortunately, I can't find any specific help in the manual.

Cheers and thanks in advance

Manu

Please Log in to join the conversation.

More
3 months 5 days ago #151096 by jelo
jelo replied the topic: How to manually set a referrer-URL
Hard to tell without the surveyfile. ID is dangerous because that might be used internal by LimeSurvey. Which version/build of LimeSurvey is used?

Try the following:
Add another shorttext question as the first question of the survey.
Name the question "xxxx", which hopefully is a name which isn't used in any context inside the survey.
Do NOT hide the question!
Your URL syntax is correct, but let's try this URL
Yourhostdomaintld/index.php/351982?xxxx=test&id=123
Is xxxx shown in the not hidden question?

manual.limesurvey.org/URL_fields
The following user(s) said Thank You: taunus

Please Log in to join the conversation.

More
3 months 5 days ago #151101 by taunus
taunus replied the topic: How to manually set a referrer-URL
Thanks, that helped!

I use a 2.62 LS hosted at my university.

Actually, the question name in the URL did not work. I have no clue why. But the predefined QTEXT from the manual worked eventually (though it also produces some answers where it doesnt work).

Anyway, I think that will do! Thank you very much

Please Log in to join the conversation.

More
3 months 5 days ago #151103 by jelo
jelo replied the topic: How to manually set a referrer-URL
Sound quite strange to me. You might create a small survey for testing and attach it here in a post. Or test on your own via the Demo.limesurvey.org to see if no server issue is causing the trouble.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now