Error on survey with tokens - user can't access the survey but answers recorded

More
4 months 3 weeks ago #171612 by LabComIZSVe
LabComIZSVe created the topic: Error on survey with tokens - user can't access the survey but answers recorded
Goodmorning everyone,

we have an issue with a survey with tokens. The invitation to answer the survey was sent to 655 contacts.

Two respondents reported that, after clicking on the link received, they viewed the message "This invitation has already been used. Sorry, but you do not have permission to access this survey. "

For the same two users, checking the table of participants it figured that their answers were recorded, although they never actually got to access it!

Does anyone know what this error may be due and how to solve it?

The Limesurvey version we use is Limesurvey Community Edition v. 3.12.1 + 180616

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171614 by tammo
tammo replied the topic: Error on survey with tokens - user can't access the survey but answers recorded
If there are recorded answers, someone must have filled in. If it was not the user that you wanted this to fill in, it must have been someone else.

Do you perhaps have short tokens, and possibly tokens that are in your token table twice?

Tammo


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template
The following user(s) said Thank You: LabComIZSVe

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171630 by LabComIZSVe
LabComIZSVe replied the topic: Error on survey with tokens - user can't access the survey but answers recorded
Hi Tammo and thanks for your help.

It could be users who forgot to have already completed the questionnaire, even if it seems strange. This is why we wanted to know if there is someone who had a similar experience, or if it can be a bug or otherwise there may be some infromatic explanation for this.

Recently, after updating to Limesurvey version 3, we also encountered another bug: when we create a new survey, the survey is automatically duplicated - so we delete one of the two surveys created and continue to work on the remaining one.

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171631 by tammo
tammo replied the topic: Error on survey with tokens - user can't access the survey but answers recorded
Hi, I never had my survey filled in by others than the invited, so it must either be:
* duplicated token (improbable)
* bug in LS (could be)
* people that have forgotten that they have filled in (depends on your use case)

The other thing that you mention, is worth another forum issue, perhaps a bug report. Please test again and if error persists, write a bug report.

www.limesurvey.org/community/bug-tracker


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template
The following user(s) said Thank You: LabComIZSVe

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #171633 by LabComIZSVe
LabComIZSVe replied the topic: Error on survey with tokens - user can't access the survey but answers recorded
Will do, thank you again

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago - 4 months 3 weeks ago #171634 by Joffm
Joffm replied the topic: Error on survey with tokens - user can't access the survey but answers recorded
hi,
please do not cross post.
It's really confusing that here Tammo and other Enlish speaking volunteers try to help, and in the Italian part you get answers from Ifanfoni.

Best regards
Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Last Edit: 4 months 3 weeks ago by Joffm.
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #171717 by jelo
jelo replied the topic: Error on survey with tokens - user can't access the survey but answers recorded

LabComIZSVe wrote: we have an issue with a survey with tokens.

What kind of token? Did you use the precreated from LimeSurvey? Or did you upload tokens created via a different way?

Can you post the two tokens, which had the issue?

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey
The following user(s) said Thank You: LabComIZSVe

Please Log in or Create an account to join the conversation.

More
4 months 2 weeks ago #171733 by LabComIZSVe
LabComIZSVe replied the topic: Error on survey with tokens - user can't access the survey but answers recorded
We used tokens created by default from Livesurvey. The two tokens were:
unRHo32B5pwOQ17
DGc5zgldkeA5leA

BTW sorry for the cross posting, we didn't think it was a problem, we'll stick to this post from now on.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!