Ranking question does work, but only in "Question by question" mode

More
4 months 1 week ago #162517 by pgs
pgs created the topic: Ranking question does work, but only in "Question by question" mode
Hello,

I have a self-hosted LS installation which works so far. Debian 9, PHP 7, Apache 2. One thing though: Ranking questions do not work. More precisely: The mouse pinter is dispalyed as hand, but one cannot drag or click the items.
I exported the question into a new test survey, and there it worked. So I switched the existing survey from "Group by group" to "Question by question", and then it worked, too.
The responsible person would like to run the survey as grup by group, though.
Is there any hint what I could look after?

Thanks in advance and regards, pgs

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #162518 by pgs
pgs replied the topic: Ranking question does work, but only in "Question by question" mode
Oh, I forgot: LS is version 3.0.3+180112.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #162521 by jelo
jelo replied the topic: Ranking question does work, but only in "Question by question" mode
Looks like a bug in LS. Please open a bugticket here: www.limesurvey.org/community/bug-tracker

Is that a fresh installation or a upgraded LS installation?

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #162522 by pgs
pgs replied the topic: Ranking question does work, but only in "Question by question" mode
Bugticket will be opened. It's a new installation, first install was 3.0.1something and yesterday I nade an upgrade to 3.0.3+180112.
BTW. The upgrade fixed some other issueswe had, but not this one.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #162523 by pgs
pgs replied the topic: Ranking question does work, but only in "Question by question" mode
Well, with my limesurvey.org-account I cannot login in the Bugtracker, and so I cannot open a ticket.

I also activeated debug mode=2, but did not get any errors.

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #162524 by pgs
pgs replied the topic: Ranking question does work, but only in "Question by question" mode
I just checked the source code of the webiste output. When the survey is configured as "Group by group", the delivered scripts are
<script type='text/javascript'>window.debugState = {frontend : (0 === 1), backend : (0 === 1)};</script><script type="text/javascript" src="/tmp/assets/26c80b7f/jquery-3.1.1.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/26c80b7f/jquery-migrate-3.0.0.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/cd55fdc5/build/lslog.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/63929fd5/min/pjax.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/8dee936d/survey.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/e6cd9fde/template-core.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/130d10a/bootstrap.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/6964414c/scripts/theme.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/6964414c/scripts/ajaxify.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/6964414c/scripts/custom.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/5c5d01c3/survey_runtime.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/b90d1243/jquery.plugin.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/b90d1243/jquery.keypad.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/b90d1243/jquery.keypad-de.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/5c5d01c3/nojs.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/4913444a/em_javascript.js" class="headScriptTag"></script>
<script type="text/javascript">
/*<![CDATA[*/
LSvar={"bFixNumAuto":1,"bNumRealValue":0,"sLEMradix":".","lang":{},"showpopup":1,"startPopups":{},"debugMode":0};
/*]]>*/
</script>

When delivered as "Question by question", they are
<script type='text/javascript'>window.debugState = {frontend : (0 === 1), backend : (0 === 1)};</script><script type="text/javascript" src="/tmp/assets/26c80b7f/jquery-3.1.1.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/26c80b7f/jquery-migrate-3.0.0.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/cd55fdc5/build/lslog.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/63929fd5/min/pjax.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/8dee936d/survey.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/e6cd9fde/template-core.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/130d10a/bootstrap.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/6964414c/scripts/theme.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/6964414c/scripts/ajaxify.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/6964414c/scripts/custom.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/5c5d01c3/survey_runtime.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/5c5d01c3/nojs.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/4913444a/em_javascript.js" class="headScriptTag"></script>
<script type="text/javascript">
/*<![CDATA[*/
LSvar={"bFixNumAuto":1,"bNumRealValue":0,"sLEMradix":".","lang":{},"showpopup":1,"startPopups":{},"debugMode":0};
/*]]>*/
</script>

So the difference is
<script type="text/javascript" src="/tmp/assets/b90d1243/jquery.plugin.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/b90d1243/jquery.keypad.min.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/b90d1243/jquery.keypad-de.js" class="headScriptTag"></script>
<script type="text/javascript" src="/tmp/assets/5c5d01c3/nojs.js" class="headScriptTag"></script>

The <li> containing the ranking question block is wxactly the same in both cases.

Maybe that helps?

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #162526 by jelo
jelo replied the topic: Ranking question does work, but only in "Question by question" mode

pgs wrote: Well, with my limesurvey.org-account I cannot login in the Bugtracker, and so I cannot open a ticket.

The Bugtracker seems to have no single-sign-on.
Try it via this link with your limesurvey.org credentials: bugs.limesurvey.org/login_page.php

If you are already logged in, you might be loggin as a guest. So you might need to logout and than login via the link.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!