problem with filter and finish later

More
4 months 2 weeks ago #155389 by twinings
twinings created the topic: problem with filter and finish later
Hello,

I have a survey with a numeric question (Q13). Later I have a filter : the number of question depends on Q13.

Q13 / With how many person do you interact ?

filter[!is_empty(Q13) && Q13.NAOK > 0] -> Q14_1 : Person 1, mail, telephone, ...
filter[!is_empty(Q13) && Q13.NAOK > 1] -> Q14_2 : Person 2, mail, telephone, ...
filter[!is_empty(Q13) && Q13.NAOK > 2] -> Q14_3 : Person 3, mail, telephone, ...
...

But when respondants push finish later, Questions on persons details (Q14) disappear. LimeSurvey seems to ignore value in Q13.

Can you help me ?

Sincerely,

Please Log in to join the conversation.

More
4 months 2 weeks ago #155395 by tpartner
tpartner replied the topic: problem with filter and finish later
Can you attach a small test survey containing only those questions?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 months 2 weeks ago #155397 by twinings
twinings replied the topic: problem with filter and finish later
Here it is.

Thanks.
Attachments:

Please Log in to join the conversation.

More
4 months 2 weeks ago - 4 months 2 weeks ago #155398 by tpartner
tpartner replied the topic: problem with filter and finish later
Well, I see at least 3 logic errors in that file. You have question validation equations like ! is_empty(Q14_1.NAOK) and ! is_empty(Q14_2.NAOK) and ! is_empty(Q14_3.NAOK) where there are only two sub-questions in that question.

Review the logic file, fix all errors and retest.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Last Edit: 4 months 2 weeks ago by tpartner.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now