Mandatory date error

More
4 months 2 weeks ago #155347 by wmaslin
wmaslin created the topic: Mandatory date error
I have a date question which is mandatory and requires month and year only. Survey has been active and this question has been working fine until yesterday when respondents advised the survey kept saying that the date question had not been answered even though it had. What could cause this to happen all of a sudden? Survey has been active for two week without any issues.

I have since deactivated the survey, changed it to drop down to make it easier for respondents, but I still get the error and the red box around the question even after it has been answered.

Appreciate any guidance. Its question code S31

Im using Version 2.65.0+170502
Attachments:

Please Log in to join the conversation.

More
4 months 2 weeks ago #155394 by wmaslin
wmaslin replied the topic: Mandatory date error
I have no idea what is going on, but it has appeared to resolve itself. Lets hope it doesn't happen again and annoy further respondents.

Please Log in to join the conversation.

More
4 months 1 week ago #155541 by olle
olle replied the topic: Mandatory date error
Hi,

There's a bug in date validation in all earlier version than 2.65.1. Please update to the latest version. This bug only appears at the end of the month, when the user chooses a month with less days than current month.

Olle

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now