Problem creating/editing templates

More
6 months 3 weeks ago #151367 by mjoos
mjoos created the topic: Problem creating/editing templates
Dear all,

I am trying to edit the default template (running a fresh install, v2.64.2+170324) but having some problems.

I RTFM'ed ( manual.limesurvey.org/The_template_edito...ating_a_new_template ) and then changed file permissions on upload/ directory, but I'm still blocked. If I try to copy a standard template I get no error but no new copy. If I try to create a new template I get no error but no new template.

I also tried to simply copy/paste the default template in upload/templates/ under a new name, but I can't edit it either even though I see it in the template editor.

Any help/hint would be appreciated!

Please Log in to join the conversation.

More
6 months 3 weeks ago #151372 by jelo
jelo replied the topic: Problem creating/editing templates
Which OS? Which PHP version? Which webserver?

Please Log in to join the conversation.

More
6 months 3 weeks ago #151732 by mjoos
mjoos replied the topic: Problem creating/editing templates
I forgot to give this, sorry.
I'm running a Raspbian Jessy with PHP 5.6.29 & Apache 2.4.10.

Please Log in to join the conversation.

More
6 months 3 weeks ago #151735 by jelo
jelo replied the topic: Problem creating/editing templates
It's a bug in your LimeSurvey version.

This file has the fix.
github.com/LimeSurvey/LimeSurvey/blob/ma.../sanitize_helper.php

You might do an update to a newer version or replace just this one file in your installation.
The following user(s) said Thank You: mjoos

Please Log in to join the conversation.

More
6 months 3 weeks ago #151745 by mjoos
mjoos replied the topic: Problem creating/editing templates
I did an update to 2.64.3, worked like a charm. I can now edit my templates. Thanks!
The following user(s) said Thank You: DenisChenu

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now