radio button and answers not in the sam line

More
6 months 4 weeks ago #151121 by mcdomell
mcdomell created the topic: radio button and answers not in the sam line
Hi,

I cannot display a radio button and corresponding label (answer) in one line. The answer is below the checkbox.
Roughly the same question has been asked here but the solution doesn’t work in my case.

Any help would be much appreciated!

mcdomell
Attachments:

Please Log in to join the conversation.

More
6 months 3 weeks ago #151132 by jelo
jelo replied the topic: radio button and answers not in the sam line
What version/build of LimeSurvey is used?
What template is used?
Best way to get help with these kind of issues is creating a survey with just one question showing the issue and provide a link to that survey running.

You might check for yourself and try the default template and see if the issue is still existing.
The following user(s) said Thank You: mcdomell

Please Log in to join the conversation.

More
6 months 3 weeks ago - 6 months 3 weeks ago #151135 by KompetenzZ
KompetenzZ replied the topic: radio button and answers not in the sam line
Hello,
I have the same issue when I insert a picture after the answer option. The radio button and the corresponding answer option is not in the same line. See screenshot. I use limesurvey Version 2.62.0+170124 and the default (standard) template.
Attachments:
Last Edit: 6 months 3 weeks ago by KompetenzZ.
The following user(s) said Thank You: mcdomell

Please Log in to join the conversation.

More
6 months 3 weeks ago #151140 by mcdomell
mcdomell replied the topic: radio button and answers not in the sam line
thanks jelo.

Limesurvey version: 2.64.1+170310

Template name: default_reloaded


Here is the link

Please Log in to join the conversation.

More
6 months 3 weeks ago #151141 by mcdomell
mcdomell replied the topic: radio button and answers not in the same line
thanks

but i can't have pictures in this question :(

Please Log in to join the conversation.

More
6 months 3 weeks ago - 6 months 3 weeks ago #151143 by jelo
jelo replied the topic: radio button and answers not in the sam line
This seems to be a updated LimeSurvey version.
The template default_reloaded seems to be a copy of the default template (from an older branch of LimeSurvey. These templates aren't updated when updating LimeSurvey. They always stay the same.

Please change the template to a one shipped with LS 2.64.Z.
E.g. default or news paper. And check again. The issue might still be there, but at least we can rule out that it is a issue from an old template.

Using old templates will cause much additional trouble down the road.
Last Edit: 6 months 3 weeks ago by jelo.

Please Log in to join the conversation.

More
6 months 3 weeks ago #151150 by mcdomell
mcdomell replied the topic: radio button and answers not in the sam line
thanks.

Indeed, when template is changed to the one shipped with LS the problem disappears. See here

However, layouts of the standard templates annoying – there is too much unused space and scrolling questions can get you a real pain in the neck

Please Log in to join the conversation.

More
6 months 3 weeks ago #151151 by jelo
jelo replied the topic: radio button and answers not in the sam line

mcdomell wrote: However, layouts of the standard templates annoying – there is too much unused space and scrolling questions can get you a real pain in the neck

You're right. www.limesurvey.org/forum/design-issues/1...es-between-questions
The following user(s) said Thank You: mcdomell

Please Log in to join the conversation.

More
6 months 3 weeks ago - 6 months 3 weeks ago #151152 by jelo
jelo replied the topic: radio button and answers not in the sam line

KompetenzZ wrote: I have the same issue when I insert a picture after the answer option.

This is not the same issue.

This is more a design decision by the template author. Where do you place the radio button when you have more than one row of text (or a image which is higher than a row of text ).

At the top of the row or the middle (what you call in line of)? I'm not sure if we can call the current behavior a bug/issue.

But feel free to open a bug ticket for a discussion about this issue.

Depending on the image dimensions a CSS might be added via the HTML editor to change the vertical position of the image. Perhaps bootstrap is already offering something. I'm waiting for LS3.0, so I'm not deep into the templates css of the current LS versions.
Attachments:
Last Edit: 6 months 3 weeks ago by jelo.

Please Log in to join the conversation.

More
6 months 3 weeks ago #151153 by mcdomell
mcdomell replied the topic: radio button and answers not in the same line
ha ha! awesome!

somehow it worked

Please Log in to join the conversation.

More
6 months 3 weeks ago #151155 by KompetenzZ
KompetenzZ replied the topic: radio button and answers not in the sam line
Ok, thank you for you the hint. Does anyone know how to do add this CSS via the HTML editor to change the vertical position of the image?

Please Log in to join the conversation.

More
6 months 3 weeks ago #151158 by jelo
jelo replied the topic: radio button and answers not in the sam line
No real hint, cause you seem to want a complete different position of the radio button.


Just outlined the different boxes and assigned float, float left and right to the images.

It is not uncommon to have the radio button in a top position.
From a different survey tool:

Attachments:

Please Log in to join the conversation.

More
6 months 3 weeks ago - 6 months 3 weeks ago #151161 by KompetenzZ
KompetenzZ replied the topic: radio button and answers not in the sam line
Thank you for the examples. My solution, as a second best solution, is this code:
<span style="vertical-align: top;">Beispiel</span>

Screenshot 1 shows the problem, screenshot 2 the solution.

Attachments:
Last Edit: 6 months 3 weeks ago by KompetenzZ.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now