Still looking where do I add Answers?

More
2 years 8 months ago - 2 years 8 months ago #139851 by Milosz
It looks like a massive community and great software but documentation is for old versions and no youtube videos.

Basic question. I am going bravely through that massive maze in the software and I would expect straight after typing the question to have some fields for Answers...
Well, there is none when you read and look around. Wait, there is a Question type label (Which I guess should actually read an ANSWER TYPE) but when I change to an array or list still nothing happens. No fields to fill in with answers and no button inviting me to click to add Answers. Going through again, previewing, going back in the maze and still no sign of how to add an answer.

Is this software really for users? I am a monkey sorry. Could someone please help monkey and guide me how do I add answers to my question?
Last edit: 2 years 8 months ago by c_schmitz.

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #139861 by fvanderstarre
Hi, depending on the question type, you will be prompted to enter answer options and/or subquestions after initially saving your question.
Just try it! Good luck.

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #139877 by Milosz
I found that now that after I SAVE the question I can see a warning somewhere in the middle of the page in the small text : 'Warning: You need to add answer options to this question ' (not sure why it gives me a warning since I didn't even had chance to fill the answers). but I think this is what you call 'prompted to enter answers'. Also there is a button at the top to Edit Answer Options but I haven't written any yet so would not presume to go there.

I think if I may suggest for future updates that there should be some kind of better 'step by step link' between the stages because I guess it is obvious that after filling the question you want to fill the answers. And the Question window kind of leaves you with question itself and you are naturally looking for the ADD ANSWER button or NEXT STEP button (like in other softwares) to know that you will fill the answers there, and that you have to accomplish the question section and then kind of separate then find it again to add answers.
But since it is free and great I will shut up now!

Please Log in or Create an account to join the conversation.

More
2 years 8 months ago #140446 by c_schmitz
Yes, we are aware of the problem here. We will certainly give the possibility to add responses/subquestions in the same dialog, soon.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #177690 by NvGnVg
Still completely unclear and not user friendly that "answers" are apparently "subquestions" to Limesurvey..

Please Log in or Create an account to join the conversation.

More
4 months 3 weeks ago #177691 by holch

Still completely unclear and not user friendly that "answers" are apparently "subquestions" to Limesurvey.

Wrong! There are both, answers AND subquestions. Some question types have subquestions (Multiple answers), some have answer options (single answers) and some have both (e.g. Matrix).

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #179121 by DenisChenu
Your survey is surely activated, just deactivate.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #179134 by KompetenzZ
Hi,
you can add a new question, see the steps on my screenshots for navigation. Or you can edit a existing question with "Edit" when you selected the question.

Cheers kompetenzz
Attachments:
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #179307 by holch
So when you are in the edit screen for the question, you click on the dropdown with the question type, in this case "long free text" and this should appear:


Here you choose the new question type you want the question to be, once you have done that, you click "select" to confirm your choice.

Should this not work in your installation, try it in the demo here on this website, just to confirm that it is a problem with your installation and not your browser or something.

If the problem is with your installation, you'll probably need to reinstall, because something went wrong. If this wouldn't work in general, the forum would be full of complaints, because this is a very essential feature of Limesurvey.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #179312 by holch
Try a different browser/computer.

If it doesn't work, sorry, then there is no way to help you, because either you are doing it wrong (not following my instructions) or something is wrong with your browser.

I just tried it on the official Limesurvey Demo here and it works just fine.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #179314 by tpartner
Do not use Internet Explorer in the back-end.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in or Create an account to join the conversation.

More
3 months 1 week ago #179317 by holch
@Tpartner: Good one! Totally forgot about Internet Explorer not being supported!

@SadafSami: Ufff, glad that it worked. I was out of possibilities.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!