The system is unable to find the requested action "checkLocalErrors"

More
2 years 2 months ago #153871 by jordipalet
I've used confortupdate a few weeks ago, everything worked fine. However, today I got (debug set to 2):


You have an error inside your local installation of LimeSurvey. See:
PHP Error [404]
The system is unable to find the requested action "checkLocalErrors". (/home/php5/limesurvey/framework/web/CController.php:483)

#0 /home/php5/limesurvey/framework/base/CErrorHandler.php(131): CErrorHandler->handleException()
#1 /home/php5/limesurvey/framework/base/CApplication.php(750): CErrorHandler->handle()
#2 unknown(0): LSYii_Application->handleException()

I've two pendings updates Security update! (Current version: 170324)
2017-04-05 11:47 and Security update! (Current version: 170404)
2017-04-19 15:28

Tried with both of them.

Version is 2.65.0 (170502).

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
2 years 2 months ago #153872 by LouisGac
Hi, 170502 is the last version of LimeSurvey. Could you please tell us what is your current build? Thank you.

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #153873 by jordipalet
I was not sure how to check the version ... so I looked into the files and found at /application/config/version.php. If this is the correct place to look for, then:

$config = '2.64.7';
$config = 261;
$config = 170404;
$config = true;
$config = '2647';

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #153874 by LouisGac
Ok I just gave a try, and I could perform an update from 170404 to 170502 without any problem.

Could you pease check the file:
application/controllers/admin/update.php

has the function called 'checkLocalErrors' (should be at line 222)?
github.com/LimeSurvey/LimeSurvey/blob/ma...dmin/update.php#L222

Please Log in or Create an account to join the conversation.

More
2 years 2 months ago #153875 by jordipalet
Yes, I've that function ... So it may be some recent Ubuntu update that broken something.
Any hint so I can investigate it?
There is any list of what php and OS apps/whatever should be installed for confortupdate to work?

Or even more, what should be the folders and group/owner (in my system seems to be everything www-data and rwxr-xr-x), I don't think this has changed with any recent OS updates ... but just in case.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago - 2 years 1 month ago #155574 by jordipalet
Still having the same problem ... I've tried to investigate if something broken in php, but all the other apps are working fine. Furthermore, may be related, "Export results to app" is no longer working!

Can someone provide any hint?
Last edit: 2 years 1 month ago by jordipalet.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #155592 by LouisGac
could you disable all plugins and try again, please?

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #155609 by jordipalet
I didn't used any, so actually, "LimeSurvey internal database" is the only one.

Should I try to disable it or it will break my actual survey data?

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #155618 by LouisGac
no it's a core plugin you can't disable it.

could you tell me please if you're using "get" or "path" for urls?

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #155620 by jordipalet
I've the default config, so not sure if that means get or path. How I can verify it?

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #155621 by LouisGac
sure: just check inside the file application/config/config.php, and look for urlFormat (it will be "get" or "path")

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #155624 by jordipalet
It is path, I guess is the default, I never changed this.

If I change to get, now I can't login to the admin, not sure if I should use an alternative URL ...

Please Log in or Create an account to join the conversation.

More
2 years 3 weeks ago #156413 by nana123
Thanks for all the good information.

Please Log in or Create an account to join the conversation.

More
2 years 3 weeks ago #156420 by jordipalet
I'm still having the problem, so not sure what is happening ...

Please Log in or Create an account to join the conversation.

More
2 years 3 weeks ago #156425 by LouisGac
ok, I'm going to create a patch for your installation.
what's your current build number?

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!