Problem sending out survey invitations

More
3 years 4 days ago #115526 by vnoelte
vnoelte created the topic: Problem sending out survey invitations
Hi,

I am trying to send out survey invitations to participants that have generated tokens. If I leave the "valid from" and "valid until" field blank for the participants, it seems as though the invitation is not being sent (the token is stated as not being valid anymore).

After including a date for the participants in the "valid from" and "valid until" fields, the invitations were sent. My issue s that I am unable to import the "valid from" and "valid until" information from a CSV. I have a survey to send to over 8000 people, which I cannot manually include this information for.

Is the "valid from" and "valid until" information required or is there a workaround? Or does anyone have a solution to making sure the "valid from" and "valid until" data from my CSV is actually imported in Lime Survey.

This is quite urgent, so your help would be much appreciated.

Thank you!

Please Log in to join the conversation.

More
3 years 4 days ago #115529 by tammo
tammo replied the topic: Problem sending out survey invitations
I have never used the fields "Valid from" and "Valid to" and I have always been able to send out invitations.

Just test is by entering your own details in the token table and send yourself an invitation. Does that work?


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
3 years 4 days ago #115532 by vnoelte
vnoelte replied the topic: Problem sending out survey invitations
Hi,

Yes I have already tested numerous times. When I try to send the invitation I get a message stating

22 Email to X (X.com) skipped: Token is not valid anymore.
All emails were sent.

Please Log in to join the conversation.

More
3 years 4 days ago #115533 by tammo
tammo replied the topic: Problem sending out survey invitations
I always test the invitation on one person only: go to the token table en click on the little envelope in the third column. Do it to your own token (with your own name/email) to test. Does that work?


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
3 years 4 days ago #115536 by vnoelte
vnoelte replied the topic: Problem sending out survey invitations
Hi,

No I get the same message...If I try a dummy token it works, but when I try to send to participants I imported from the CSV it doesn't work.

Please Log in to join the conversation.

More
3 years 4 days ago #115538 by tammo
tammo replied the topic: Problem sending out survey invitations
And what happens when you start a new survey, with one group, one question (any type) and a token table with just your details in it?

Tammo


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
3 years 4 days ago #115540 by vnoelte
vnoelte replied the topic: Problem sending out survey invitations
Hi Tammo,

I just tried your suggestion and it didn't work. I get the same message that the "Email was skipped: Token is not valid anymore"...

Please Log in to join the conversation.

More
3 years 4 days ago #115541 by tammo
tammo replied the topic: Problem sending out survey invitations
Here my knowledge reaches it's limit. i hope someone else, with more knowledge on this, will chime in.

I wish you success.


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
3 years 4 days ago #115543 by vnoelte
vnoelte replied the topic: Problem sending out survey invitations
Hi Tammo,

Thank you for your help. Do you know if there is a CSV template that has the "valid from" and "validuntil" fields filled out and which has successfully been uploaded to Lime Survey (where Lime Survey populates the info as it does for the name and email info)? Basically if I can get the CSV to import properly, I would be able to send out the surveys...

Thanks again,

V

Please Log in to join the conversation.

More
3 years 4 days ago #115545 by tammo
tammo replied the topic: Problem sending out survey invitations
Just fill in a (1) token fully and export it to CSV. That will give you the basic structure.


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
3 years 3 days ago #115551 by holch
holch replied the topic: Problem sending out survey invitations
Exactly as Tammo said (and how I explained in the other thread). Make one manual entry in the token table, export it. Then have a look how the information is formated and based on that prepare your token table in csv. I have given you an example how it worked for me.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 3 days ago #115552 by holch
holch replied the topic: Problem sending out survey invitations
What I don't understand is why your emails are not sent, because they don't have a valid date, because I have never used the valid date in the tokens either and it is not a problem.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
3 years 1 day ago #115592 by Mazi
Mazi replied the topic: Problem sending out survey invitations

holch wrote: What I don't understand is why your emails are not sent, because they don't have a valid date, because I have never used the valid date in the tokens either and it is not a problem.

Could be a bug or any other invalid information being imported from CSV file like a wrong "emailstatus" flag.

Which Limesurvey version do you use?

Can you reproduce the problem at our Demo which always runs the latest code?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!