Token mismatch when reopening the same survey through a different token

More
3 years 3 months ago #109331 by mascarpone
mascarpone created the topic: Token mismatch when reopening the same survey through a different token
Dear all,

I am on version 2.05+ Build 140502.

I have a survey that I manage through tokens (one per user). The first time I access the survey through a token, no problem. But if I then try to re-acess it through another token, I get the following "error" message:

Token mismatch

The token you provided doesn't match the one in your session.

Click here to start the survey.


Any idea why that is the case and if/how this could be resolved so that there is no "token remanence" sort of...?

I have found a similar discussion in the Issue Tracker, here: bugs.limesurvey.org/view.php?id=7853 but not sure this is actually the same problem - ?

Merci!

Please Log in to join the conversation.

More
3 years 1 week ago #112447 by mascarpone
mascarpone replied the topic: Token mismatch when reopening the same survey through a different token
Problem - linked to session cookies - had actually been solved.

Please Log in to join the conversation.

More
1 month 19 hours ago #157834 by marycgc
marycgc replied the topic: Token mismatch when reopening the same survey through a different token
We are having the lime survey version 2.67.3+170728. we are currently experiencing this same problem again. Could you let us know how to solve this issue.

Please Log in to join the conversation.

More
1 month 8 hours ago #157847 by DenisChenu
DenisChenu replied the topic: Token mismatch when reopening the same survey through a different token
But : it's the needed and default behaviour … and the sentence is clear … to be sure to reset the session add &newtest=Y or /newtest/Y to your url …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
1 month 1 hour ago #157866 by marycgc
marycgc replied the topic: Token mismatch when reopening the same survey through a different token
Thank you I added /lang/en/newtest/Y to the URL. it worked correctly. Thank you for your help

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now