Placing limesurvey in i-frame issues in Safari

More
4 years 2 months ago #99902 by doeckee
doeckee created the topic: Placing limesurvey in i-frame issues in Safari
Hi, I'm keen to insert limesurvey into an iframe that works within Safari.
At the moment I can't progress past the 1 page of my survey within safari without an error message.
Does anyone know how to fix this???
Please help!!

Please Log in to join the conversation.

More
4 years 2 months ago #99912 by tpartner
tpartner replied the topic: Placing limesurvey in i-frame issues in Safari
What is the error message? I have tested in Safari 5 and have no problems.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
4 years 2 months ago #99929 by doeckee
doeckee replied the topic: Placing limesurvey in i-frame issues in Safari
Thanks for your response. I actually don't receive an error message but it doesn't move past the first screen of the survey within the i-frame when it's in Safari. All other browsers work fine.
I keep clicking 'next' and the survey does nothing.

Please Log in to join the conversation.

More
4 years 2 months ago #99934 by tpartner
tpartner replied the topic: Placing limesurvey in i-frame issues in Safari
Does the survey work in Safari without the iframe (in the top frame)?

Try using the shipped default template and if you still have the problem attach an export of a sample survey for us to test.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
8 months 4 weeks ago #148875 by fcazalas
fcazalas replied the topic: Placing limesurvey in i-frame issues in Safari
Hi, I know this ticket is quite old, but I still have an error message when using iframe with Safari whereas it is ok with Firefox, Chrome and even IE ;).
I've read that Safari blocks 3rd party cookies but I don't know what to do to solve this ? Do you have any idea ?
Thanks !

Please Log in to join the conversation.

More
8 months 4 weeks ago #148878 by LouisGac
LouisGac replied the topic: Placing limesurvey in i-frame issues in Safari

fcazalas wrote: I've read that Safari blocks 3rd party cookies but I don't know what to do to solve this ? Do you have any idea ?


all web browsers are moving to this behaviour... and it's going to be hell for all applications using iFrame to mashup applications.... and it's a lot of professional applications.... :dry:

possible "solution":
discussions.apple.com/thread/4156939?tstart=0

Please Log in to join the conversation.

More
8 months 4 weeks ago #148881 by fcazalas
fcazalas replied the topic: Placing limesurvey in i-frame issues in Safari
yes...this seems complicated for me ;) I'll give it a look later; thank you

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!