Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Question Type Array, run time error on answer options with variables

Question Type Array, run time error on answer options with variables il y a 1 an 1 semaine #107442

  • Bart
  • Portrait de Bart
  • Hors ligne
  • Junior Lime
  • Messages : 35
  • Karma: 0
This question ran fine in release 1.92.
After upgrade to 2.05, when running the survey, it gaves an error.

However,
running the QA logic file gives no error (see attachment)
also, previewing the question does not give an error. (see attachment)

First attachment shows the error when running the survey question.
Pièces jointes :
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 1 semaine #107452

  • holch
  • Portrait de holch
  • Hors ligne
  • LimeSurvey Team
  • Messages : 3360
  • Remerciements reçus 455
  • Karma: 145
I see that you are on LimeService. They have a specific support there. As it is their server, they probably know better what is going on.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 1 semaine #107457

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 7020
  • Remerciements reçus 939
  • Karma: 282
HI,

Seems there are some update to do when updating from 1.92.
1st : Update each question text, go to source and set ' to ' (or replace with ")
2nd : NEVER use = for a condition, use == : manual.limesurvey.org/Expression_Manager...t_Operator_.28.3D.29
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 5 jours #107472

  • Bart
  • Portrait de Bart
  • Hors ligne
  • Junior Lime
  • Messages : 35
  • Karma: 0
I was not succesful in fixing this issue.
I tried regular editing, pop-up editor Html plain and pop-up HTML editor within in "code modus".
All with the same result: no errors in QA Logic file, but errors during run-time.
Indeed, system detects the HTML-code for ': & # 039.
But even though I delete manually the original ' with a new ': no success.

Perhaps something within the settings: disable inline HTML-editor???
Or: can I use a plain editor externally and then copy plain code to the editor?
Can I use an external editor, and change the code to UTF-8, or something?
Is there a way to look "under water" if the HTML-code is being used, before testing
(testing is cumbersome, since I have to go to bunch of questions before I arrive at the question with the troubled code).

Could export and import solve the problem?
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 5 jours #107475

  • Bart
  • Portrait de Bart
  • Hors ligne
  • Junior Lime
  • Messages : 35
  • Karma: 0
Also, some more input.

I copied the question.
I change the question type from Array to Array (Text).
Now the problem doesn't appear.

If I change the new (copied) question to question type Array, the problem reoccurs.
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 5 jours #107477

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 7020
  • Remerciements reçus 939
  • Karma: 282
I just test with a 2.05 version with HTML editor on : really no problem.
In last GIT version : no problem too (HTML editore with/without XSS)

What is your LS version ?

Think best is to deactivate inline HTML editor
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 5 jours #107479

  • Bart
  • Portrait de Bart
  • Hors ligne
  • Junior Lime
  • Messages : 35
  • Karma: 0
I am on 2.05+
I cannot find out which build, but I upgraded Last Wednesday, so I guess latest build.

BTW: I disabled the inline HTML-editor.
I can still use the inline HTML-editor, at subquestion level (not at question level)
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 5 jours #107486

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 7020
  • Remerciements reçus 939
  • Karma: 282
Hi,

HTML editor in popup is really the best solution.
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 5 jours #107492

  • Bart
  • Portrait de Bart
  • Hors ligne
  • Junior Lime
  • Messages : 35
  • Karma: 0
The pop-up HTML-editor doesn't really save the changes.
If you make changes within the pop-up HTML-editor, and then save within the HTML-editor,
and run QA logic file, the changes are not shown.
You have to close the pop-up HTML-editor, and then push "Save" in the main screen, to actually save the changes.
It might be that the HTML-codes are incorporated once more once you save in the main screen.
L'administrateur a désactivé l'accès en écriture pour le public.

Question Type Array, run time error on answer options with variables il y a 1 an 19 heures #107667

  • Bart
  • Portrait de Bart
  • Hors ligne
  • Junior Lime
  • Messages : 35
  • Karma: 0
*** solved ***
I solved the issue with a workaround.
The error was triggered by using the ' in a subquestion.
I used a 'subscription'.
The system detected HTML-code, which could not be resolved.
I introduced an additional field, with the use of a equation question, so the field subscription with the value subscription.
In the subquestion I no longer used a string between the ' and ',in this case 'subscription' but used the newly introduced equation field {subscription}
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.143 secondes
Donation Image