"Did not save" on survey load

Plus d'informations
il y a 3 mois 4 jours #168708 par dgeils
dgeils a créé le sujet : "Did not save" on survey load
I have a windows server with IIS and FastCGI PHP 7.0 installed with MSSQL 2016. I have attempted to install LimeSurvey 3.6 and 3.7+180508. I get this error "Did not save" error when I select the survey link.

If I ignore the link and complete the survey, it places a new line in the database with no survey field information, value of null, for each page it encounters. Since my test survey only has one question, I get a record for the welcome page, a record for the survey page and a record for the completed page. All of these records have NULL for the question information.

I see many issues similar prior to 3.0 but no solutions.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 4 jours #168724 par LouisGac
LouisGac a répondu au sujet : "Did not save" on survey load
seems that someone else faced a very similar problem here:
www.limesurvey.org/forum/installation-a-...db-connection-failed

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 4 semaines #169087 par dgeils
dgeils a répondu au sujet : "Did not save" on survey load
This is after a survey is created and is attempted to be taken. I am far beyond the installation of Lime Survey. The survey is built and stored in the database. The issue is no one may take the survey because no answers may be stored in the database.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #169655 par korbink
korbink a répondu au sujet : "Did not save" on survey load
Same problem here. My setup:

Limesurvey version: 3.9.0+180604
MS SQL version: 2016
PHP version: 7.2 (connecting to SQL using PDO driver 7.2)

The error displays right as the survey loads with: "Did not save

An unexpected error has occurred and your responses cannot be saved.

Your responses have not been lost and have been emailed to the survey administrator and will be entered into our database at a later point."



I have tried creating a single question survey and get the same result.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #169664 par holch
holch a répondu au sujet : "Did not save" on survey load
both using MS SQL... sounds like it would be interesting to follow this lead.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169885 par korbink
korbink a répondu au sujet : "Did not save" on survey load
Are there any logs or anything I can provide to help troubleshoot this issue? As it stands right now survey users' responses are not being saved.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169886 par dgeils
dgeils a répondu au sujet : "Did not save" on survey load
I have turned on logging and receive no more information. I have completely changed and installed using Apache 2.4 with PHP 7.0. Basically, the only thing the same is SQL Server 2016. I receive the same issue. This leads me to the conclusion SQL Server 2016 must not work with the latest versions.

What I see as a difference with SQL Server 2016 is the DBO is set by the database and cannot be configured to what LimeSurvey expects.

Finally, the other area I am not sure of is the anonymous handling. Since creating a survey utilizes a person logged into the system, it allows you to create the survey. When a person takes the survey, they are not logged in.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169888 par holch
holch a répondu au sujet : "Did not save" on survey load
Did anyone of you create a bug report?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169889 par dgeils
dgeils a répondu au sujet : "Did not save" on survey load
I created two and paid for support. Both were closed with unable to reproduce locally.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169890 par holch
holch a répondu au sujet : "Did not save" on survey load
What does "paid for support" mean??

Well, difficult to fix something, they can not reproduce.

I hope you provided all necessary information. Do you have links to the bug reports, just out of curiosity?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169891 par dgeils
dgeils a répondu au sujet : "Did not save" on survey load
I did not make a bug report because support could not reproduce so I assumed it would be closed just as quickly.


www.limesurvey.org/support?view=ticket&l...=view&ticketid=11091
www.limesurvey.org/support?view=ticket&l...=view&ticketid=10869

As for the question of paid support, it is really for upgrade purposes. I am actually upgrading but my current version is 1.87 which is outside the upgrade support window.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169892 par holch
holch a répondu au sujet : "Did not save" on survey load
OK, I don't know how the support works. But generally the support is for their products (hosting of current version and comfort update). Might be that a bug report is closed equally quick, don't know.

Of course I don't have any access to a support ticket between you and the Limesurvey GmbH.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 6 jours #169894 par dgeils
dgeils a répondu au sujet : "Did not save" on survey load
I am currently working on moving to 2012 SQL Server which is v11, v12 is where Azure became the standard. Our old installation is with 2008 SQL Server. I can see some differences in MSSMS so I am hoping this will solve my problem. I will post my results so others may learn from my issue.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #170182 par dgeils
dgeils a répondu au sujet : "Did not save" on survey load
I finally was able to test with 2012 SQL Server. I am still having the same issue with limesurvey3.7.2+180508.zip with both Apache and IIS. (Yes, I have installed both separately to eliminate any of the issues.)

Here is what the DB table looks like once I attempt to take the survey.

id token submitdate lastpage startlanguage seed 922767X1X1SQ001 922767X1X1SQ002 922767X1X1SQ003 922767X1X2SQ001 922767X1X2SQ002 922767X1X2SQ003
1 NULL NULL NULL en 563747071 NULL NULL NULL NULL NULL NULL
2 NULL NULL NULL en 563747071 NULL NULL NULL NULL NULL NULL
3 NULL NULL NULL en 563747071 NULL NULL NULL NULL NULL NULL
4 NULL NULL NULL en 563747071 NULL NULL NULL NULL NULL NULL

Basically, each time the survey loads it writes a record to the table. It is unable to update the record it wrote.

There has to be a setting missing or some configuration LimeSurvey support takes for granted but the rest of us do not know about.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #170191 par holch
holch a répondu au sujet : "Did not save" on survey load
Well, depending on your settings, Limesurvey either creates a new line in the data base (token based response persistence OFF) or updates the previous entry (response persistence ON). Or did I understand your new problem wrong?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!