Fragentexte bei Pflichtfragen verschwinden bei Nicht-Beantwortung

Plus d'informations
il y a 2 mois 3 semaines #184716 par KatKei
Hallo,

ich habe ein Problem bei meiner Befragung. Einige Fragen sind als Pflichtfragen deklariert. Wenn diese nicht ausgefüllt werden, erscheint wie gewohnt beim Weiter-Klicken das Hinweisfeld und die jeweiligen Fragen sind rot hinterlegt. Problem ist nur, dass der Fragentext nicht mehr erscheint.

Vielleicht weiß jemand, woran das liegen könnte?

Vielen Dank im Voraus!

Liebe Grüße


Meine LS- Version 2.50+ Build 160415 , Windows 7, Firefox und Internet Explorer
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 2 mois 3 semaines - il y a 2 mois 3 semaines #184721 par holch
Sorry, aber deine Version ist jetzt über 3 Jahre alt und wurde schon sehr, sehr lange nicht mehr upgedated. Wenn ich mir die Versionsnummer ansehe, dann war das eine (wenn nicht DIE) erste Version dieses Zweigs von Limesurvey und der hatte am Anfang noch arge Probleme mit Bugs. Es gab daraufhin fast tägliche Updates zur Fehlerbehebung.

Meiner Meinung nach sollte man diese Version auf keinen Fall in der Produktion einsetzen. Am besten gleich zu 3.x upgraden. Es ergibt keinen Sinn Fehler in dieser Version zu suchen oder zu beheben. Durch all die Updates die es seither für diese Version gab, kann dieses Problem behoben sein. Es macht wirklich keinen Sinn über Bugs in so einer alten und ungepachten Version zu diskutieren, zu mal diese längst EOL (End of Life) ist. Das heisst, dass selbst wen dieses Problem in der Letzten Version dieses Zweiges noch bestehen würde, gäbe es keine Bugfixes mehr. Die Entwicklung konzentriert sich jetzt schon voll auf LS 4.0 (welches in der Beta-Fase ist) und LS 3.0 hat bereits einen Feature-Stop, d.h. es gibt nur noch Bug-Fixes und Security-Updates, aber es kommen keine neuen Features mehr dazu.

3 Jahre ist eine lange Zeit in der Webentwicklung und wie du siehst gabe s schon (fast) zwei neue Major Releases in dieser Zeit.

Also, entweder versuchen ein Update auf die letzte Version deines Zweiges zu machen und sehen was passiert oder idealerweise gleich in den sauren Apfel beissen und auf die aktuelleste stabile Version (3.x) updaten.

Mit der 2.50+ sollte man idealerweise nicht mehr im Internet unterwegs sein, vor allem nicht, mit einem Tool das Daten sammelt uns speichert.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Dernière édition: il y a 2 mois 3 semaines par holch.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #184723 par holch
Nochmal ich: Habe mir jetzt mal den Screenshot angesehen und das Template deutet daraufhin, dass du ein Template aus dem 2.06 LTS Zweig verwendest.

Das kann nicht gut gehen, da diese Templates nicht Kompatibel mit 2.50 sind. Also mal mit einem Standard-Template das mit 2.50 gekommen ist testen.

Nichts desto trotz: Diese Version sollte NICHT mehr produktiv eingesetzt werden. Meiner Meinung nach.

Kannst du mal einen Screenshot von deiner Admin-Umgebung machen, damit wir sicher sein können um welchen Zweig es sich wirklich handelt? Denn dem Survey-Template nach sieht es nach 2.06 LTS aus.

Ich konnte eine Version 2.50+ Build 160415 auch in den Changelogs gar nicht finden.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #184733 par KatKei
Hallo holch,

herzlichen Dank für Deine schnelle Antwort. Da ich nicht der Administrator von dem Zugang bin kann ich Dir leider keine genaue Antwort zu den verschiedenen Versionen geben. Aber ich hatte auch schon die Vermutung, dass das Problem an der alten Version liegen könnte. Ich habe die Infos an die Administratoren weitergegeben. Gibt es Erfahrungen dazu, ob ein Update viele alten Daten "zerstört" oder läuft das meist recht problemfrei?

Danke und viele Grüße

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 3 semaines #184748 par holch
Seit einigen Jahren ist ein Update bei Limesurvey eigentlich meist problemlos. Vor allem das Comfort-Update (muss bezahlt werden, aber wenn man LS wirklich produktiv verwendet, sollte der Wert eigentlich nicht die Welt sein, verglichen mit der Zeit die der Admin spart) ist da eigentlich ein Riesenfortschritt. Aber auch manuell kann man eigentlich ganz einfach updaten.

Innerhalb des selben Zweigs ist es im Normalfall (keine grösseren individuellen Anpassungen an der Installation vorgenommen) relativ einfach.

Bei Grösseren Versionssprüngen, z.B. vom 2.50 Zweig auf 3.0 werden individuelle Templates z.B. nicht funktionieren.

Wie bei jedem Update ist es natürlich empfehlenswert eine Sicherheitskopie/Backup der Installation vor dem Update/Upgrade zu machen. So kann man im Notfall wieder zurückwechseln.

Wenn man immer regelmässig Updates fährt, ist die Gefahr von Problemen im Normalfall auch immer geringer als jetzt von einer der ersten Versionen dieses Zweigs auf die aktuelleste zu gehen. Es dürfte keiner bisher diesen direkten Weg getestet haben. Der Sprung ist einfach recht gross.

Und offensichtlich hat es der Admin deiner Installation sowieso nicht so mit Updates, sonst hätte man diese Installation nicht über 3 Jahre ungepached gelassen.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Les utilisateur(s) suivant ont remercié: KatKei

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!