Relevance equation pointing to box of array/numbers, checkbox layout

Plus d'informations
il y a 2 mois 1 semaine #181390 par frederikbrandenstein
COM_KUNENA_MESSAGE_CREATED_NEW
Hi everybody!

I'm stuck with the following (running LS 3.16.0):

For judging the relevance of question 2, I want to check whether a box in question 1 (Array, Numbers, Checkbox-Layout) was checked.

I thought it should be sth. in line with:
((question1_ya_xa.NAOK==1))

Didn't work, I do not get addressing the subquestion or its value right.

MWE attached, all help highly appreciated.

THX

Frederik

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 2 mois 1 semaine #181409 par frederikbrandenstein
COM_KUNENA_MESSAGE_REPLIED_NEW
update
see MWE attachement added.
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine - il y a 2 mois 1 semaine #181410 par tpartner
COM_KUNENA_MESSAGE_REPLIED_NEW

Didn't work, I do not get addressing the subquestion or its value right.

Did you check the logic file for errors?

If the question/sub-question codes are correct, try this:

!is_empty(question1_ya_xa.NAOK)

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com
Last edit: il y a 2 mois 1 semaine by tpartner.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #181414 par frederikbrandenstein
COM_KUNENA_MESSAGE_REPLIED_NEW
Tony,

it works with your equation -- but only if I display the questions groupwise (sth. that took me some time to work out).

Is it possible to make it work in a "question by question" setup thus is it supposed to be limited to groupwise display?

Attached, find another MWE.
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #181425 par tpartner
COM_KUNENA_MESSAGE_REPLIED_NEW
Why not use group-by-group and place questions in separate groups.

Sorry, I cannot review your file this week, I am contributing via phone.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #181426 par jelo
COM_KUNENA_MESSAGE_REPLIED_NEW

frederikbrandenstein écrit: Is it possible to make it work in a "question by question" setup thus is it supposed to be limited to groupwise display?

I would recommend group display. But you might be the victim of the AJAX mode.


Deactivate the mode in your survey theme settings and try again. It should work then in question by question mode too.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Pièces jointes :
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine - il y a 2 mois 1 semaine #181427 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW

frederikbrandenstein écrit: Is it possible to make it work in a "question by question" setup thus is it supposed to be limited to groupwise display?

I can confirm it work (with the first lss file) without ajax mode (and question by question mode).
But it's broken with ajax mode.

You muts report this (major) issue : www.limesurvey.org/community/bug-tracker

Personnaly : i disable ajax mode always !

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Last edit: il y a 2 mois 1 semaine by DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine - il y a 2 mois 1 semaine #181428 par Joffm
COM_KUNENA_MESSAGE_REPLIED_NEW
sorry, wrong post

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Last edit: il y a 2 mois 1 semaine by Joffm.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #181462 par jelo
COM_KUNENA_MESSAGE_REPLIED_NEW

DenisChenu écrit: But it's broken with ajax mode.

The other way around. AjaxMode as a feature is broken. But an official statement about why it is worth to debug and test this feature, is still missing.

bugs.limesurvey.org/view.php?id=14616

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #181467 par frederikbrandenstein
COM_KUNENA_MESSAGE_REPLIED_NEW
Okay everybody,

thank you very much for your quick response and help,

to wrap it up:

I filed a bug report: bugs.limesurvey.org/view.php?id=14620

I tested switching off ajax mode in the rather complex survey I am putting together and that works, so that will be the appropriate solution in my case.

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!