Please use the LimeSurvey navigation buttons or index. It appears you attempted

More
2 years 7 months ago - 2 years 7 months ago #119249 by caioschiavo
caioschiavo created the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
when people clicks next on a page the browser shows me this

"Please use the LimeSurvey navigation buttons or index. It appears you attempted to use the browser back button to re-submit a page"

and go back

I apply this survey to my students. They respond in the school computer lab, and limesurvey is hosted on a paid web server , does the fact that the computers IP be the same externally may have something to do with it ?

PHP Version 5.3.10-1ubuntu3.15

LimeSurvey
Versão 2.00+ Build 130103



i attach my survey

File Attachment:

File Name: limesurvey...9Web.lss
File Size:328 KB
Attachments:
Last Edit: 2 years 7 months ago by caioschiavo.

Please Log in to join the conversation.

More
2 years 7 months ago #119254 by Mazi
Mazi replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Please test your survey at our Demo which always runs the latest version: Demo.limesurvey.org/admin

There can be several reasons for this issue. If you are lucky it is just a minor bug which is fixed at the latest version.

Which exact link do you use to start the survey?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
2 years 7 months ago #119275 by caioschiavo
caioschiavo replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
link web.nossolar.web.br.com

i tested on limesurvey Demo and it goes ok

Please Log in to join the conversation.

More
2 years 7 months ago #119286 by Mazi
Mazi replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Maybe updating your Limesurvey system solves the problem.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
1 year 9 months ago - 1 year 9 months ago #132240 by frederikprijck
frederikprijck replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Hi guys,

We're experiencing the exact same problem.

Infrastructure:
Running LS Version 2.06+ Build 160123 on Microsoft Azure.
Browsing using Google Chrome 48.0.2564.109

Survey Settings:
Allow back = false
Session persistence = enabled
Token persistence = disabled
The enquete is open without token (test phase)

Issue:
The user is filling in the enquete and (very) occasionaly, when he clicks next, the user is redirected to the same page showing all the questions in red (being invalid). A popup is shown containing the following text: Please use the LimeSurvey navigation buttons or index. It appears you attempted to use the browser back button to re-submit a page.

How the user can progress:
Close the browser and reopen it.

The problem is random and not very often. However it is occuring and making it impossible for the user to finish the survey without closing the browser and starting over again.

Any ideas ?
Last Edit: 1 year 9 months ago by frederikprijck.

Please Log in to join the conversation.

More
1 year 9 months ago #132249 by Mazi
Mazi replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
It is always tricky to track this down if this happens randomly. There can be two main reasons:

1. Temporary insufficient server resources to process the request.

2. Invalid conditions causing internal logic errors for certain answer combinations.

It may be possible to track down #2 if you know about some record IDs for which the navigation issue shew up. Compare the answers and maybe you see a pattern.
And of course, always check the survey logic file.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
1 year 9 months ago #132250 by frederikprijck
frederikprijck replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Hi,

1. We use the scaling features of Azure + our machines are pretty oké so I doubt that resources/specs can be an issue ... Or am I wrong here ?
2. Wouldn't this mean that the issue always occurs when doing the exact same actions ? Im 99% sure that we use the same actions and the issue only happens sometimes (and realy sometimes, like 1 out of 500).

Btw I forgot to mention: The survey is not live, so we are still in DEV / TEST phase. So we have 1 or 2 concurrent users. So resource problems would be pretty odd.

Please Log in to join the conversation.

More
1 year 9 months ago #132251 by Mazi
Mazi replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
@1: If the survey is very complex and contains lots of questions I can only think about runtime time outs or the like. But most probably no server issue, I agree.

@2: I don't know if you are using any conditions and how many questions and combinations of questions/conditions exist so it is hard to say.

3. Problems may occur during testing if you are stopping the survey, switch back to the admin screen, reload several admin screens and survey logic screen, open Limesurvey and the survey in several tabs at the same browser and then get back to your previous survey session.
It may mix up survey session under certain circumstances.

As so often: If we can't safely reproduce it, we can't fix it.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
1 year 9 months ago #132253 by frederikprijck
frederikprijck replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Hi,

2. We have about 80 - 100 question with 20 - 30 conditions.
3. The admin application was never open, we never closed and reopend the survey.
The only thing that can have happend is that we are idle for a few minutes (MAX 10). But session timeout is > 10 min.

Is there any logs i can look in to ?

No worries, I'm a developer aswell. I know there is nothing worse than issues you can't reproduce :(

Please Log in to join the conversation.

More
1 year 9 months ago #132257 by tpartner
tpartner replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Can you pin it down to one group and give us a sample survey with that group?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
1 year 9 months ago #132259 by frederikprijck
frederikprijck replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
The problem is we can not actualy pin point the problem.
It happens randomly and not even that often. But that makes us even more worrying about what the cause could be ... :(

Currently the problem occurs when switching pages between groups.
Do you mean a single group with one question per page ?

Please Log in to join the conversation.

More
1 year 9 months ago #132266 by Mazi
Mazi replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Probably both, could be the whole group or a question within the group.

@logs: Limesurvey doesn't log such issues. Only thing I can think of is server logs.

One further issue could be another application using the same folder for storing session data and wiping out that session.
But I think the error message would be different.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
1 year 9 months ago #132536 by frederikprijck
frederikprijck replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
One more thing I can tell you guys is:

Since we are in development phase, we are not using tokens. Hence we have the feeling that at some point LimeSurvey's session state has failed and LS has troubles matching the entries in *prefiex*_survey_*surveyId* table (where token == null).

After this point, the survey tool is broken in such a way that every client enters a inifinite loop in which he is constantly navigated between the welcome page and the first survey question. Restarting the server works, or waiting for a bit results in the problem going away.

Please Log in to join the conversation.

More
1 year 9 months ago #132554 by Mazi
Mazi replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
Please file a bug report.

Thanks!


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
1 month 2 weeks ago #160059 by blocka
blocka replied the topic: Please use the LimeSurvey navigation buttons or index. It appears you attempted
I'm wondering if a bug was ever identified for this?

I have a survey running now that is exhibiting the same problem -- but I'm running the most recent build (171120).

Randomly participants see: "Please use the navigation buttons or index. It appears you attempted to use the browser back button to re-submit a page."

Sessions use the database, and session lifetime is 4 hours.

The survey has 640 questions (many are hidden based on conditions), and probably 80% of the questions have conditions on them (we provide random scenarios, and present a small subset of the questions to each participant - ergo all the questions & conditions).

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!