Email Issues - Add new User Emails Fail

Mehr
1 Monat 1 Woche her #194250 von marcgold
Wonder if anyone can shed some light on a small issue.

We are using the SMTP relayed Via AWS SES service. We have a survey setup with tokens and the emails work perfectly without error.


However, When we create a new admin user the email to notify them of their password fails with the following.

2020-02-19 12:43:20 CLIENT -> SERVER: QUIT

Add user
Warning


Email to field_admin (marc@*********.co.uk) failed.

But there is nothing in the Server Logs.

Any Idea's.

Limesurvey Version 3.22.3+200211
Plesk Onyx Server PHP 7.3.14
Web: NginX

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
1 Monat 1 Woche her - 1 Monat 1 Woche her #194253 von tpartner
In your Global settings --> Email settings, are the "Default site admin email" and the "SMTP username" the same.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com
Letzte Änderung: 1 Monat 1 Woche her von tpartner.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her #194255 von marcgold
Thanks for the quick response.
No they are not, but this is correct.
the default admin email is the correct one as setup in AWS as an authorised sender.

The SMTP username is a 16 Char Alpha name as supplied from AWS ie:
ABCDEFGHIJKLMNOP

The setting work perfectly for sending survey token emails. Just not for adding new users.

Marc

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her - 1 Monat 1 Woche her #194258 von jelo
Is it only this emailadress or and emailadress which fails? Did you check Token again. Is that still working?

The CLIENT -> SERVER: QUIT is not informative enough. You would need the complete handling LOG.

How old is the SES-Account?

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Letzte Änderung: 1 Monat 1 Woche her von jelo.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her - 1 Monat 1 Woche her #194260 von marcgold
Yeah, the first thing i checked was if the Token email were working and they are faultlessly.

I have checked the log files, and there is nothing there at all, but i'm guessing this is correct as LS is relaying via SMTP.

SES is very strict with authentication - its almost as though Token emails are using the details as set: but Admin emails are not.
Letzte Änderung: 1 Monat 1 Woche her von marcgold.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her - 1 Monat 1 Woche her #194263 von jelo

marcgold schrieb: I have checked the log files, and there is nothing there at all, but i'm guessing this is correct as LS is relaying via SMTP.

What logfiles. You can only see the communication between the SMTP server and LimeSurvey when you activate the debug options in the Mail settings of LimeSurvey.

SMTP debug mode - It comes with three options:
Off (default value): The user wants this activated only in the case in which the SMTP relay does not work and further details are needed in order remedy the technical problem
On errors : A detailed connection log and error message will be given if an error occurs
Always : It gives valuable information on how a SMTP relay works. If an error occurs, further details are provided


Personnally I doubt that the adminuser email sending part is checked/debugged as good as the token sending part. Perhaps the emails for users are not send via SMTP at all.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Letzte Änderung: 1 Monat 1 Woche her von jelo.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her #194264 von marcgold
Cracked it!!! :laugh:
Thanks for everyone ideas.


So the cause was the bounce email address - this was a different email address so they can be auto processed.

If anyone is using AWS SES (or similar services that need emails verified) then you must verify all email address that will appear in the mail header.

Ie: From , Return & Bounce.

Hope this thread helps someone else in the future.

Marc

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her #194265 von jelo

marcgold schrieb: So the cause was the bounce email address - this was a different email address so they can be auto processed.

Since you solved the issue, you might explain why you can send token emails, but no user emails via the same mail-configuration settings?

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 1 Woche her - 1 Monat 1 Woche her #194272 von marcgold
Hi Jelo

The reason that token emails worked was the bounce email address was set as the sender address but the general configuration email system one was different.

At a survey level you have the option to override the system set values.

Simple really.
Letzte Änderung: 1 Monat 1 Woche her von marcgold.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha