V4.1.1 installation assistance

Mehr
1 Monat 3 Wochen her #193699 von Tim_JH
Hello, I'm hoping someone here can assist me. Trying to install v4.1.1 (latest self-hosted stable release) on Windows 2016/IIS and can't get the initial installer to launch when going to http://localhost/limesurvey/admin. Have installed WebPlatform/PHP 7.4 which seems to be working fine as phpinfo is displaying fine with mbstring enabled. No error is returned, it looks like the page redirects to /limesurvey/index.php?installer but then no page or error is provided and from iis log appears to loop trying to load that page. I believe the iis_user permissions are set correctly as noted in the manual and I've tried setting php paths to /tmp and /temp (as in the manual) and neither has helped. I'm hoping/expecting this to be a simple issue/mistake that I've made but I'm lost so any help that can be provided is much appreciated. Thanks

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
1 Monat 3 Wochen her #193782 von zbirdman777
I ran into the same issue. I was able to overcome it by setting the directory permissions to read and write for the limesurvey/tmp directory and limesurvey/upload directory.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 3 Wochen her #193786 von Tim_JH
Thanks for the response, unfortunately it doesn't look like a permissions issue, at least on a limesurvey directory as iis_usrs has read+write permissions and I have file audit on for any failure event and nothing is showing in the security log. I do think it's something simple/along these lines but I can't put my finger on it for the life of me....any other insights/thoughts would be great....thanks

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194083 von Tim_JH
I think we got it working and just as an 'fyi' for any others that may stumble upon this same issue, I'll post an update here. We had tried adding the limesurvey directory/site both as just a new directory under inetput\wwwroot and as a virtual directory but what seemed to get it working for us was using the 'add application' option from the default site and using the default app pool (v4.0 .NET). At least we get the 'Welcome'/select your language installer page to show up now and not sure why that step isn't in the install guide but there you go.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194109 von DenisChenu
Can you try with LTS version before ?
www.limesurvey.org/lts-releases-download


I have 2 IIS installation but none with WebPlatform version of PHP ... and none with 4.X version.
Since even with mysql and apache : there are a lot of issue, i'm sure there are more with IIS+MSSQL

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194124 von holch
I am always wondering why we are not just dropping MSSQL support completely. I only see problems coming up and LS is never suficiently tested on the MS platform. Why not just dropping it completely? I mean I don't see other big OSS software like Wordpress providing MS support and they are just doing fine.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194131 von DenisChenu

holch schrieb: I am always wondering why we are not just dropping MSSQL support completely. I only see problems coming up and LS is never suficiently tested on the MS platform. Why not just dropping it completely? I mean I don't see other big OSS software like Wordpress providing MS support and they are just doing fine.

Maybe we can inform user we have "automatic test" for mariadb and mysql, but no test for MSSQL (seems we have now PGSQL test).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194160 von Tim_JH
So this thread wasn't really about DB aspect of config but since it's been brought up and we're using MS SQL, I'll give some additional information we figured out (sure it's somewhere else as well). We had to download SQL drivers ( docs.microsoft.com/en-us/sql/connect/php...iew=sql-server-ver15 ) and add entries to PHP.INI. Apparently MS Web Platform PHP (latest 7.4) uses non-thread-safe (NTS) so had to copy those to \ext folder and add these two entries to bottom of PHP.INI file:

extension=php_sqlsrv_74_nts_x64.dll
extension=php_pdo_sqlsrv_74_nts_x64.dll

and then, after IIS restart, MS SQL was an option in the drop down during the install....I'll drop more info as we get thru this if anything seems like a struggle for us and maybe helpful for others.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194161 von holch
Ohh, ok, of course, with a missing driver it won't work with MSSQL. There is little LS developers can do.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194164 von cdorin
Hey Tim, if you find more info about that, could you please update the manual entry as well? manual.limesurvey.org/Installation_-_Lim...rvey_on_your_website . It could help a lot of MS SQL users in the near future.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194215 von Tim_JH
Further updates....for MS SQL, after getting PHP PDO SQL drivers loaded, had to install a more recent version of ODBC drivers than are in place with the operating system. Got those here, ( docs.microsoft.com/en-us/sql/connect/odb...river-for-sql-server ).

then when trying to update are old DB, got this error "CDbCommand failed to execute the SQL statement: SQLSTATE[42000]: [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Explicit value must be specified for identity column in table 'lime_question_themes' either when IDENTITY_INSERT is set to ON or when a replication user is inserting into a NOT FOR REPLICATION identity column."

found this bug report, bugs.limesurvey.org/view.php?id=15841 , and commented out line 2960 (and a few after it) in C:\limesurvey\application\helpers\update\updatedb_helper.php and reran the upgrade script and looks good now.

I'll consider trying to update the manual, just I'm a newbie and wouldn't want to send anyway astray with their efforts as everyone's mileage may vary.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
1 Monat 2 Wochen her #194232 von jelo

Tim_JH schrieb: I'll consider trying to update the manual, just I'm a newbie and wouldn't want to send anyway astray with their efforts as everyone's mileage may vary.

That's understandable. You might open a bugreport or add your comments to a bugreport. That way your workarounds and findings are not lost in the ocean of forum posts and users with the same issue can consult the bugreport.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha