Displaying Emojis from imported files

Mehr
2 Monate 1 Woche her #179194 von ferdeng
COM_KUNENA_MESSAGE_CREATED_NEW
Dear all,

I have the following problem.

I exported my survey as txt, edited it and imported it again. Everything works great.

The only thing that doesn't work are emojis.
For example, my imported txt contains a grinning Emoji. I saved the txt encoded survey to be imported as UTF-8. Everything works after the import process, except for the emoji which is displayed as ????.

I also tried adding "<meta charset="UTF-8">" at the beginning of the question as a code, but that didn't change anything. Strangely, when I manually edit the question in LS and just paste the emoji, it's displayed correctly. So it seems that LS can display emojis, the problem must be with the import process.

How can I fix this?

Thanks in advance!

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

LimeSurvey Partners
Mehr
2 Monate 1 Woche her #179217 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
I'm sure you use excel, this is a broken tool : use LibreOffice calc : www.libreoffice.org/download/download/

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Folgende Benutzer bedankten sich: LouisGac

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her #179218 von ferdeng
COM_KUNENA_MESSAGE_REPLIED_NEW
Dear Denis,

thanks for your reply. Indeed, I first tried to do this with excel, but I didn't even manage to import one single question. That's why I already did everything in libre office. But don't get me wrong, the Emoji is also correctly display in Libre (as a Emoji, not as a codepoint). And even in the txt when I open it with the editor (still as the real emoji).

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her #179233 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
But then : where it'sdiplay has not an emoji ?

I check myself : seems OK

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her #179239 von ferdeng
COM_KUNENA_MESSAGE_REPLIED_NEW
If it do it manually (by that I mean editing a question in Limesurvey directly), it works, yes.
If I import my survey from a txt document (and exported survey I manipulated to add more questions), everything except for the emojis works. I only get to see ???? instead of the emoji. I tried both encoding as ASCII and UFT 8.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her - 2 Monate 1 Woche her #179240 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
When is say i check i
- Export as TSV
- Update with LibreOffice
- Save as TSV (UTF8, tab separator)
- Import

And it's OK

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last edit: 2 Monate 1 Woche her by DenisChenu.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her #179241 von ferdeng
COM_KUNENA_MESSAGE_REPLIED_NEW
So you exported as TSV, edited the question (added an emoji) with Libre, saved as txt again, imported and it's working?

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her #179269 von ferdeng
COM_KUNENA_MESSAGE_REPLIED_NEW
Even tried the following thing now: I imported the manipulated survey with emojis, they're not shown (only ????). They I exported this version again, edited with libre office (replaced ???? with the emoji), imported again to Limesurvey. But still, it's only displayed as ???? again.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 6 Tage her - 2 Monate 6 Tage her #179281 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW

ferdeng schrieb: So you exported as TSV, edited the question (added an emoji) with Libre, saved as txt again, imported and it's working?

Yes



I add another emoji, save as utf8 : and it's OK



PS : another idea : linux rules !

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Anhang:
Last edit: 2 Monate 6 Tage her by DenisChenu.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 6 Tage her #179324 von ferdeng
COM_KUNENA_MESSAGE_REPLIED_NEW
Thanks for trying this! Are they also displayed correctly when you store them inse a question? And if you test the survey? I don't know what I could do differently...

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 5 Tage her #179333 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
Yes

Can you send me a sample (not working) tsv file ?
Here is mine

Dateianhang:

Dateiname: limesurvey...3731.zip
Dateigröße:3 KB

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Anhang:

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 5 Tage her #179362 von ferdeng
COM_KUNENA_MESSAGE_REPLIED_NEW
Of course!
Anhang:

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 5 Tage her #179369 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
It's OK on my 2 server … (5.6 and 7.2 / linux)


Maybe related to server … maybe try to report the issue with all information

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Anhang:

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha