devbridgeAutocomplete doesn't work when welcome screen is shown

More
1 year 2 months ago - 1 year 2 months ago #177429 by KompetenzZ
Hi community,

I use this autocomplete plugin by DenisChenu: gitlab.com/SondagesPro/QuestionSettingsType/autoComplete
Unitil yesterday this plugin worked fine but today it became really frustrating with this plugin. Now I realized that it does not work when the welcome screen is shown in:
"Survey settings -> Presentation -> Show welcome screen: ON"

Now I tried something else and then I realized it's not only the welcome screen that makes the autocomplete plugin troubles. Anytime the autocomplete question is not on the very first survey page (start counting on the welcome screen, if displayed), it does not work (no autocomplete suggestions are shown).

Is there anything that I can to so this plugin also works on others than the first page?

Attached is a test survey with this behavior. Together with a csv file for the autocomplete suggestions. To become the test survey working, the autocomplete plugin needs to be installed before (can be downloaded on the link above).

File Attachment:

File Name: limesurvey...4171.lss
File Size:14 KB

File Attachment:

File Name: bundeslaen...iste.csv
File Size:0 KB

Cheers kompetenzz
Attachments:
Last edit: 1 year 2 months ago by KompetenzZ.

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 year 2 months ago #177440 by tpartner
Disable AJAX in the theme options.


Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com
Attachments:
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #177448 by KompetenzZ
Thank you very much, that is the issue. AJAX mode would have not come to my mind. Now it works fine.

Cheers kompetenzz

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #177455 by DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 year 2 months ago #177664 by KompetenzZ
Ok, I did it :)

Cheers kompetenzz
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!