surveys all crashed because of the EM bug

More
2 years 8 months ago #111470 by iscar
iscar created the topic: surveys all crashed because of the EM bug
update from 2.0 to 2.05.if your survey has EM like {if(a>=3,'','')}
,you will see attached situation.
it seemed EM in 2.05 still has little problem,and cannot suport html tag

i am crying now!!
Attachments:

Please Log in to join the conversation.

More
2 years 8 months ago #111476 by Ben_V
Ben_V replied the topic: surveys all crashed because of the EM bug
Have you clear the browser cache?

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
2 years 8 months ago #111493 by iscar
iscar replied the topic: surveys all crashed because of the EM bug
sure,i have got the reason, it's because of the EM.
EM is core function, i have post this problem but nobody pick it.
i think lots of people will face this problem when update to 205.

Please Log in to join the conversation.

More
2 years 8 months ago #111496 by holch
holch replied the topic: surveys all crashed because of the EM bug
Sorry, but it is not clear to me.

You say that if you put the code
{if(a>=3,'','')}

into a survey, this will destroy the backend of Limesurvey??

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 8 months ago #111498 by holch
holch replied the topic: surveys all crashed because of the EM bug
I just did a quick test and inserted the code you provided into the question text and into the relevance equation, saved it but all looks fine.

Could you describe this problem a little bit further, so that it can be reproduced? Where do you put this code?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

More
2 years 8 months ago - 2 years 8 months ago #111499 by Ben_V
Ben_V replied the topic: surveys all crashed because of the EM bug
A said by Holch, it's very hard to believe that EM is the source of the problem...
Your screenshot only shows that the issue is related with the (not correctly linked or/and missing) admin stylesheet.

Check that /styles/gringegreen/adminstyle.css file is correctly uploaded.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last Edit: 2 years 8 months ago by Ben_V.

Please Log in to join the conversation.

More
2 years 8 months ago #111505 by c_schmitz
c_schmitz replied the topic: surveys all crashed because of the EM bug
Yeah, clear your browser cache first, please!

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now