Error message "Base table or view already exists" while updating from 2 to 2.05

More
2 years 7 months ago #111448 by polarbearcv
I'm trying to update my Limesurvey installation from 2.00+ build 130708 to 2.05 stable version.
My server configuration is
Ubuntu server 13.10
Apache 2.4.6
PHP 5.5.3
MySQL 5.5.37

I first took a copy of my installation to another server to test the update.
When I run the Comfortupdate the 4 steps of the Limesurvey installation itself go well.
Then I get an information screen for the update of the database. (see below)

Database-upgrade
Controleer de volgende informatie voordat u doorgaat met de upgrade van de database:
Database-type: mysql
Database-naam: limesurvey2
Tabel voorvoegsel: lime_
Naam website: Testmanager
Root-URL: /limesurvey2/index.php/admin/update

But when I continue I always (i already tried a few times) get the errormessage:
CDbCommand failed to execute the SQL statement: SQLSTATE[42S01]: Base table or view already exists: 1050 Table '`limesurvey2`.`lime_plugins`' already exists

I tried to locate this lime_plugins table in the phpmyadmin interface of my database but it isn't there.
I tried raising the memory_limit to 2048MB in the php.ini and the config-defaults.php since my database is 134 MB big (size on harddisk)
Can someone help me with this problem?
Thanks in advance and best regards,
Marc
Attachments:

Please Log in to join the conversation.

More
2 years 7 months ago #111459 by c_schmitz
Just a hint: If your update failed you need to restore the backup and try again - continuing on the database of a failed try will produce unrelated errors.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
2 years 7 months ago #111477 by polarbearcv
I tried a few times to reinstall my backup first but its the same problem.
I also tried to check the consistency of the database which advised me to delete some old tables which I did but nothing else.

Is there anything I can check or do to debug this problem?

Best regards,

Marc

Please Log in to join the conversation.