Admin Password

More
3 years 2 months ago - 3 years 2 months ago #110595 by jimstarks
jimstarks created the topic: Admin Password
Hey guys, I know this has been covered a dozen times and I've read through and tried all of the solutions including this one, which seems like it should work:

INSERT INTO `lime_users` VALUES(1, 'admin', 0x35653838343839386461323830343731353164306535366638646336323932373733363033643064366161626264643632613131656637323164313534326438, 'Administrator', 0, 'en', 'This email address is being protected from spambots. You need JavaScript enabled to view it.', 'default', 'default', 'default', '', 1,'2014-03-12', '2014-03-12');

In any case, here's what happened. I lost connection with the server and when my network came back up Limesurvey basically wouldn't do anything, so I shut down and restarted. But when I restarted, I could not log back into Limesurvey. I tried the password reset which doesn't work, tried commenting out the code that checks for a correct password... you name it. I'd do a fresh install (I'm using 2.05+ 20140422), but I'm afraid of losing the surveys that I have in there. And, of course, I'm skirting a deadline.

Any thoughts are GREATLY APPRECIATED! Thanks...JIM
Last Edit: 3 years 2 months ago by DenisChenu. Reason: Use of example.com, done for this

Please Log in to join the conversation.

More
3 years 2 months ago #110596 by Ben_V
Ben_V replied the topic: Admin Password
Have you tried with the link "Forgot your password?" below the admin login form?
You will receive a new password by email ...
.

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
3 years 2 months ago #110597 by jimstarks
jimstarks replied the topic: Admin Password
Ah, didn't mention that one, but yes I tried that as well. It was, of course, the first thing I tried. I do get the email, but it won't sign in.

If I go into the lime_users table admin record, it doesn't actually set a one time password...the field is blank.

Thanks...

Please Log in to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #110608 by Ben_V
Ben_V replied the topic: Admin Password
I attached you the complete lime_users table for LS 2.05
Paste everything in the sql query box
(check if "lime" is the correct prefix)

username => admin
password => pass

Hope it works

Ben

EDIT: Note that it will remove all other users

File Attachment:

File Name: lime_users_2.05.txt
File Size:1 KB

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Attachments:
Last Edit: 3 years 2 months ago by Ben_V.

Please Log in to join the conversation.

More
3 years 2 months ago #110609 by jimstarks
jimstarks replied the topic: Admin Password
Thanks, did not work either... I do have lime_ table prefixes, but it looks like I have leftover files from a previous version without lime_. That shouldn't matter, though, should it?

On another note, and it just occurred to me that it could have something to do with it. I upgraded to faster service yesterday and they moved everything to a new server/IP. Still if all the files are there and intact, I wonder why that might cause problems.

Is there a way to extract my projects and just do a fresh install without logging in?

Thanks again, appreciate the help.

Please Log in to join the conversation.

More
3 years 2 months ago #110613 by Ben_V
Ben_V replied the topic: Admin Password
1) the tables prefix is defined in the config.php file so it does not have to appear elsewhere in the files. So it is probably OK.

2) If you cannot access the admin page your problem is not an admin/password issue but more to connect with the files or database.. This could be perfectly linked to your server update for example something related to .htacess file.

3) You can dump the entire database with PhpMyAdmin, do a fresh (local or remote)installation and overwrite the blank database importing your SQL dump...

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Please Log in to join the conversation.

More
3 years 2 months ago #110749 by jimstarks
jimstarks replied the topic: Admin Password
Thanks again, for the help, Ben. You're right. Somewhere along the line, admin.php is getting information from the database (it's checking my user name and email address), but won't write to it (won't set a one-time PW field).

It looks like the upgrade/move was indeed the culprit, though I can't be sure why. I'm going to just do a fresh install.

I do appreciate the effort... thanks...JIM

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now