end url with variables not longer working after limequery update 3.13.2

More
11 months 3 weeks ago #171667 by geert
I get following error message after submitting the form:
We are using the Cloud version. If I leave out the variables everything is working fine.
www.i-hd.eu/mailing/mail.cfm?email={A1_S...{A15}&subject=AC2018

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171677 by Joffm
Hi,

having a look at your end-url I see that the curly bracket in front of "lastname-variable" is missing.

I created a small survey just to fill the fields and got


Best regards
Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:
The following user(s) said Thank You: LouisGac

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171689 by DenisChenu
About end url, it's always more easy to create a Equation question type and do your url inside.

The you can easily test and fix it.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: LouisGac

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171701 by geert
Thank you for your help! That was a very stupid typo.
But it's not the real problem.
All of the variables get an extra span tag so the url ends up looking like this:
www.i-hd.eu/mailing/mail.cfm?email= <span id='LEMtailor_Q_0_9'>This email address is being protected from spambots. You need JavaScript enabled to view it.</span>&title=<span id='LEMtailor_Q_0_10'>Mrs</span>&firstname=<span id='LEMtailor_Q_0_11'>Inge</span>&lastname=<span id='LEMtailor_Q_0_12'>Lamote</span>&dinner=<span id='LEMtailor_Q_0_13'></span>&monday=<span id='LEMtailor_Q_0_14'>Y</span>&tuesday=<span id='LEMtailor_Q_0_15'></span>&workshop=<span id='LEMtailor_Q_0_16'>A1</span>&membership=<span id='LEMtailor_Q_0_17'>A1</span>&subject=AC2018

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171702 by DenisChenu

geert wrote: Thank you for your help! That was a very stupid typo.
But it's not the real problem.
All of the variables get an extra span tag so the url ends up looking like this:

Seems to be an issue about static VS non-static var.
We have a params in the function. Someone lost this param during a fix.

Please : try to create a simple lss to report the issue.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171704 by geert
Thanks! I will report the bug.
The following user(s) said Thank You: LouisGac

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago - 11 months 3 weeks ago #171705 by Joffm
Hi, geert,
well, this is something different.

Just entering your provided url throws your described error in your application.

But what is your goal? Do you want to keep the "spans", or not?

To get rid of them you can use the function "strip_tags"?



Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:
Last edit: 11 months 3 weeks ago by Joffm.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago - 11 months 3 weeks ago #171711 by jelo

Joffm wrote: But what is your goal? Do you want to keep the "spans", or not?

I don't get that. Where is the Limesurvey URL? The Coldfusion-application could clean the URL, but the issue seems to be a LimeSurvey adding extra stuff.

Let's wait till the bugticket and example is posted. Since it is a limesurvey server under control of LimeSurvey GmbH a solution or explanation for that issue should be possible.

@geert: Please post a link to your bugticket here. Thanks.

Update:
bugs.limesurvey.org/view.php?id=13905

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Last edit: 11 months 3 weeks ago by jelo.

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171721 by DenisChenu

jelo wrote: I don't get that. Where is the Limesurvey URL?

+1

1. Since redirect url is done at end of Survey : no need javascript update, then no need span (like in completed text).

If there are span there are an issue with step (EM think current step is step of Q 9) => 1st issue

2. Since redirect url must be done after survey completed : we can enforce static value here => 2nd issue

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171728 by jelo

DenisChenu wrote:

jelo wrote: I don't get that. Where is the Limesurvey URL?

+1

The question was for Joffm. He followed a URL. In the thread I only see a URL to a cfm application.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171731 by Joffm
@jelo:
Exactly, I talked about this url:
www.i-hd.eu/mailing/mail.cfm?email= <span id='LEMtailor_Q_0_9'>ingelamote@gmail.com</span>&title=<span id='LEMtailor_Q_0_10'>Mrs</span>&firstname=<span id='LEMtailor_Q_0_11'>Inge</span>&lastname=<span id='LEMtailor_Q_0_12'>Lamote</span>&dinner=<span id='LEMtailor_Q_0_13'></span>&monday=<span id='LEMtailor_Q_0_14'>Y</span>&tuesday=<span id='LEMtailor_Q_0_15'></span>&workshop=<span id='LEMtailor_Q_0_16'>A1</span>&membership=<span id='LEMtailor_Q_0_17'>A1</span>&subject=AC2018
This address throws the error because of the tags.

And therefore I proposed to use "strip_tags" to clean the url.

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171737 by jelo
Isn't the question: Why did LimeSurvey create such a URL? It's the EndURL, not the input into LimeSurvey.

The bugticket has a a surveyfile attached with EndURL
www.XXX.eu/mailing/mail.cfm?email={A30 }

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
11 months 3 weeks ago #171739 by DenisChenu

Joffm wrote: And therefore I proposed to use "strip_tags" to clean the url.

Hi Joffm : i'm unsure strip_tags work here.

I think you have javascript strip_tags in EM function , but still have external span (needed for javascript function).


:)

Sorry @jelo for missunderstanding

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!