Audio File Upload

More
4 years 3 weeks ago #119554 by KatieQ
Audio File Upload was created by KatieQ
Hi,

I am attempting to upload an audio file as part of a question in my survey. I am using the following code (including an example of the audio):

<audio controls>
<source src="/upload/surveys/447514/images/19.mp3" type="audio/mp3">
</audio>

After pasting this code into the source view, the audio controls appear exactly as I want them and the audio file can be played.

However, the audio control does not appear in the question preview. Further, when I save the question, the audio control disappears from the question and the code is removed/deleted from the source view.

If anyone can explain why this is happening, it would be much appreciated.

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
4 years 3 weeks ago #119555 by KatieQ
Replied by KatieQ on topic Audio File Upload
Sorry, I think that this should have been asked under the 'Can I do this with LimeSurvey?' topic.

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #183172 by anisij
Replied by anisij on topic Audio File Upload
Dear Katie,

Kindly we are facing the same problem with regular users, but this problem doesn't happen with admin account.

Best regards,
Anis

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #183188 by holch
Replied by holch on topic Audio File Upload
You will most probably have to switch off the XSS filter.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!