get_session_key API call returns "Invalid user name or password"

More
1 week 3 days ago - 1 week 3 days ago #184442 by alefebvr
Hello,

I'm trying to use the JSON RPC API and I've tested the following curl commands for now.
We have LimeSurvey Version 3.16.1+190314 installed.
curl --data-binary '{"jsonrpc":"2.0","method":"get_session_key","params":["adminuser","password"],"id":1}' -H 'content-type: application/json' https://our.limesurvey/index.php/admin/remotecontrol 
 
curl --data-binary '{"jsonrpc":"2.0","method":"get_session_key","params":{"username":"adminuser","password":"password"},"id":"1"}' -H 'content-type: application/json' https://our.limesurvey/index.php/admin/remotecontrol 
Both return:
{
    "error": null,
    "id": 1,
    "result": {
        "status": "Invalid user name or password"
    }
}
though I can log into the portal with the adminuser and password.

Is there anything I'm missing?
What is "id":1 (should it be 1? something else?)

Thanks in advance for your reply,

Best,

alex
Last edit: 1 week 3 days ago by alefebvr.

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 week 2 days ago #184476 by DenisChenu
Your account are allowed to log in via Auth DB ? If it's a LDAP account, you must use
get_session_key(username,password,'AuthLDAP');

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

More
1 week 2 days ago #184483 by alefebvr
Thanks Denis, worked first time round!!

Please Log in or Create an account to join the conversation.

More
1 week 2 days ago #184484 by alefebvr
PS: Note that I couldn't find the documentation about this "AuthLDAP" parameter, should I open an issue for this?

Please Log in or Create an account to join the conversation.

More
1 week 1 day ago - 1 week 1 day ago #184565 by DenisChenu

alefebvr wrote: PS: Note that I couldn't find the documentation about this "AuthLDAP" parameter, should I open an issue for this?

Yes please, and put the link here …

The manual need to be updated (but the api autodoc is OK).

And send warning about : Auth system NEED (currently) by default a user/password

Need to update Plugin Auth information too about the new params (i must contraol param name). Then another Auth can be done (sample uniquid in php file).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Last edit: 1 week 1 day ago by DenisChenu.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!