Version 3.17.16+190906 cannot upload file

More
3 months 3 weeks ago #190317 by matthevv
When I am trying to upload file, I find the javascript error onto the page.

After checking, there are a few checkbox onto left panel that use frame of red color to specify the location in below image.

So, upload button is not work due to the javascript problem. Could any person figure out what's problem is going on?

Please help with me. Thank you.

Please Iniciar sessão or Create an account to join the conversation.

LimeSurvey Partners
More
3 months 3 weeks ago #190324 by jelo

matthevv wrote: So, upload button is not work due to the javascript problem.

That might be a followup error. The root cause is currently unclear.

First check via different browsers. Consider updating LimeSurvey to a newer version.
You might consider asking the administrator of the LimeSurvey installation.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Iniciar sessão or Create an account to join the conversation.

More
3 months 2 weeks ago #190495 by matthevv
However, how to occur the javascript error? what mistake is took in this situation?

Please Iniciar sessão or Create an account to join the conversation.

More
3 months 2 weeks ago #190500 by DenisChenu

matthevv wrote: However, how to occur the javascript error? what mistake is took in this situation?

Hard to know …

Partial information, take time to analysis …

Did you have some 403 or 404 error in the log, what other error you have ?
etc …
www.limesurvey.com/support

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Please Iniciar sessão or Create an account to join the conversation.

More
3 months 2 weeks ago #190505 by matthevv
It show me that no error log here. But, it is grateful if you could show me how to switch to the development mode of limesurvey. It may show the error message to me.

Please Iniciar sessão or Create an account to join the conversation.

More
3 months 2 weeks ago #190515 by DenisChenu
On 1st pîcture : its show 6 error, but we have only one …

403 error are shown in console of the browser …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Please Iniciar sessão or Create an account to join the conversation.

More
3 months 2 weeks ago - 3 months 2 weeks ago #190638 by matthevv
I cheked version 3.15.5 that when the kcfinder will load a ajax at page load

third_party/kcfinder/browse.php?type=files&lng=en&act=init&kcfinder_csrftoken=xxxxx

However my new version do not do so. missing this ajax call.

I investigate the code. you can check third_party/kcfinder/js/050.init.js and find "buildTree(" keywords. The closure actually is what the ajax code located

is that the new version problem causing this incident ?
Last edit: 3 months 2 weeks ago by matthevv.

Please Iniciar sessão or Create an account to join the conversation.

Começar agora!

Basta criar a sua conta e comece a usar o LimeSurvey hoje mesmo.

Registar agora
Subscreva o nosso boletim informativo!

Iniciar sessão