How to add multiple Surveys from one domain and autoplay for audiofiles

Plus d'informations
il y a 1 semaine 5 jours #172164 par BusyBonsai
BusyBonsai a créé le sujet : How to add multiple Surveys from one domain and autoplay for audiofiles
Dear all,

we are using the free version of Offlinesurvey and hosting Limesurvey ourselves at version 2.73. We want to run the surveys both online and offline. Now we struggle at adding multiple surveys to the app.
After one survey has been added successfully, when adding a second survey from that domain, an error message appears saying that a survey with either the same survey-ID, URL or Survey name already has been added. Which is not true as the given arguments are:
Survey nameSurvey IDSurvey URL
name x599345 survey.wzb.eu/index.php/599345?lang=pl
name y866824 survey.wzb.eu/index.php/866824?lang=pl
name z828948 survey.wzb.eu/index.php/828948?lang=pl

On the website we can't find any information on a limitation like this for the free version, just the max. 10 locked surveys, which we wouldn't reach anyway. Is it just not working or do we miss anything?

Help is much appreciated!

Best regards

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 semaine 5 jours #172165 par BusyBonsai
BusyBonsai a répondu au sujet : How to add multiple Surveys from one domain and autoplay for audiofiles
Guess I cannot change the Threads name. Forget about the second part, the autoplay for audiofiles. (I'll explain why below)
So in two of these three surveys we use audiofiles that read out loud the question texts when the pages are loaded. Doing the surveys on the offline app, the audiofiles are implemented but the autoplay-setting doesnt work. However, it just came to my mind that on the app the survey is presented group by group, so it would play several audiofiles at the same time, which would not help.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 semaine 5 jours #172180 par aaskoura
aaskoura a répondu au sujet : How to add multiple Surveys from one domain and autoplay for audiofiles
Hi,
about the error, this has nothing to do with free or pro. Mainly survey name duplication is what causes this error... please send your survey details to support email support [at] offlinesurveys.com and they will come back with exact issue..

About playing audio when a group is shown in OfflineSurveys... this is doable.. OfflineSurvey fire an event "render" when showing a group or a question, you can handle it the same way as in www.offlinesurveys.com/ufaqs/how-to-impl...er-in-offlinesurveys it should work fine

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 semaine 4 jours #172200 par BusyBonsai
BusyBonsai a répondu au sujet : How to add multiple Surveys from one domain and autoplay for audiofiles
Dear aaskoura

thanks for you reply. I guess survey name, survey ID and survey URL are all relevant "survey details"? I'll write to the support then!

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 semaine 12 heures #172309 par BusyBonsai
BusyBonsai a répondu au sujet : How to add multiple Surveys from one domain and autoplay for audiofiles
Hello again,

so meanwhile I've managed to understand and use your code specified in www.offlinesurveys.com/ufaqs/how-to-impl...er-in-offlinesurveys .
Btw on notice - the code in the 'download as sample LimeSurvey Question' is missing the '$('#question' + {QID}).hide();'-line. I am not sure whether it's supposed to.

So for some reason I can't make the timer work; whether its 90000 or 2000 milliseconds the audio would play immediately when the page is loaded (which doesn't concern me that much, since I want to simulate autoplay anyways).
So running the survey online on a windows computer, the audio is being played. However when I now try to update/synchronize the survey to the offline app, it gives me Error15: "Caching of survey details aborted due to Javascript-mistakes in the survey." (as I'd translate from German to English). When I simply comment out the code I can synchronize, deleting the comment tags gives the error again. Can you help me here? I attached the Code as a .txt-file if needed.

Fichier attaché :

Nom du fichier : audioplay.txt
Taille du ficher :1 ko


Help will be much appreciated!
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!