welcomeModal is not displayed - possible bug

Plus d'informations
il y a 6 jours 2 heures #172269 par roehle
roehle a créé le sujet : welcomeModal is not displayed - possible bug
Hi there,

we noticed that the welcomeModal intended for first time users is not being displayed (\application\views\admin\super\welcome.php) in our upgraded installation (3.14.2+180807).
Diggin into it we came to the following:
If it is displayed depends on
if($countSurveyList==0  && Permission::model()->hasGlobalPermission('surveys','create')
If you check the definition of the variable $countSurveyList you find that in \application\controllers\admin\index.php
it is defined as
$aData['countSurveyList'] = Survey::model()->count();
(counting all surveys of the installation) whereas it used to be
$aData['countSurveyList'] = count(getSurveyList(true));
(all surveys owned by currently logged in user) which still works if it is changed back to that.
Is this a bug or are we missing something? It does not make sense to use the number of all available surveys here, right?

Stefan

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 jours 1 heure #172276 par tpartner
tpartner a répondu au sujet : welcomeModal is not displayed - possible bug
Please file a bug report.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!