Error after updating LimeSurvey to latest version

Plus d'informations
il y a 4 mois 1 semaine #168816 par Matadeleo
Matadeleo a créé le sujet : Error after updating LimeSurvey to latest version
Hi,

I've set up a new server running the Latest version of LimeSurvey and I'm using ComfortUpdate to keep it up to date.


Current LS:
Version 3.7.3+180516

However, I'm seeing an error appear all over the place - but especially when editing existing questions.

The error:
Internal Server Error
Property "SurveyDynamic.refurl" is not defined.

The error doesn't seem to prevent things from happening - if I edit the question text of a question then save, I get that error, but if I go back to the page, the change has been made.

Anyone got any ideas how I can get rid of this annoyance?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 mois 1 semaine #168831 par elissa
elissa a répondu au sujet : Error after updating LimeSurvey to latest version
Hi, I'm not an expert in those server issues but recently I had problems with Internal Server Error and colleagues suggested that this may be caused by some damaged files that may be corrupted during ftp transfer ( www.limesurvey.org/community/forums/inst...stallation-and-error ). Actually, that was the issue. I transferred the (same) files again and everything is OK now. Of course your issue may be completely different. Just a suggestion.

Cheers

Elzbieta Lesinska
LS voluntary Polish translator and supervisor

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 mois 1 semaine #168835 par Matadeleo
Matadeleo a répondu au sujet : Error after updating LimeSurvey to latest version
I've experienced similar issues myself with uploading via FTP, however this install was done on an AWS linux server, I downloaded the tarball from LimeSurvey straight to the server and extracted.

Since the code seems to be looking for something it can't find, it sounds like a similar issue - but I don't know how I would go about tracking down the problem file and replacing it with a fresh one.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 mois 1 semaine #168867 par John_K
John_K a répondu au sujet : Error after updating LimeSurvey to latest version
Yes- I too get a similar error when attempting to create a new user in LS 3.7.2 or when attempting to import an existing survey from LS 2.0.6 - Displays an error, but when I open LS in a new tab, I can see the new entry. Though I'm not sure if all relevant data is getting populated to required referential tables at DB level. Not sure what/where to check.
Interestingly, the import of an .lss survey to LS 3.7.2 does not populate the diff groups & questions in the survey- Only the survey summary & not the rest of the survey structure.
JK

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 mois 1 semaine #168921 par holch
holch a répondu au sujet : Error after updating LimeSurvey to latest version
I guess you guys won a bug report. Please go to bugs.limesurvey.org to retrieve your prize... ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 3 semaines #169311 par Matadeleo
Matadeleo a répondu au sujet : Error after updating LimeSurvey to latest version
Hi Holch, apologies for the delay I was on holiday. Did a bug report get created for this, or do you just hint that one of us create one?

I'm not sure how to find if someone else has already made a report for it, and not sure I can provide all the information required.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 3 semaines #169326 par holch
holch a répondu au sujet : Error after updating LimeSurvey to latest version
OK, I tried to be funny but probably wasn't very clear: you should create a bug report for this. Bug reports are best created by those that experience it and can reproduce it. It doesn't make sense for me to create a bug report, because it is you that knows your environment and what is happening.

To find out if someone else has mad a similar bug report, you can search in the bug database. But even if a bug is reported twice, it is probably better than not reported at all.

However, you should first check if the problem persists in the latest version and there have been a couple since you started this thread.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 3 semaines - il y a 3 mois 3 semaines #169336 par Matadeleo
Matadeleo a répondu au sujet : Error after updating LimeSurvey to latest version
Sorry I ruined your joke :blush:

I will do like you said and update to latest version when my projects are complete, and if problem persists will try to get ll the required info for bug report.

The bug for me seems to occur on: Version 3.7.3 & Version 3.8.0+180522

And to reproduce - if I activate survey and make edits to text then I get a server error:
Internal Server Error
Property "SurveyDynamic.refurl" is not defined.

Seems to be failing to send me back to the page I made the edit from, after changes are made. Hitting back button twice takes me back to LimeSurvey and I can continue.
Dernière édition: il y a 3 mois 3 semaines par Matadeleo.

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!