Cannot update from 1.92+ to 2.51.3+

Plus d'informations
il y a 2 ans 1 mois #141378 par marius2
marius2 a créé le sujet : Cannot update from 1.92+ to 2.51.3+
Hello,

I've downloaded my Limesurvey website to localhost to try make update from 1.92 to 2.51 before trying on production server.

As written in Docs I've deleted all old files and copied new ones. Left only old config.php, /upload, /tmp directories.
Opened http://localhost/lime/admin/, choosen language, all requirements passed, entered db, dbuser, dbpassword (it didn't recognize current database...), then it opened database upgrade window:
Database upgrade
Please verify the following information before continuing with the database upgrade...

I clicked on "Continue.." and after ~1-2mins it just opened url http://localhost/lime/index.php/admin/databaseupdate/sa/db/continue/yes and it was written: All 3 user templates updated.

When I tried go to http://localhost/lime/admin/ or Home page it gave me error:
Internal Server Error
CDbCommand failed to execute the SQL statement: SQLSTATE[42S22]: Column not found: 1054 Unknown column 't.allowjumps' in 'field list'
An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.
Thank you.

I have tried to restore backup database and make this db upgrade one more time, but it still gets the same error message...
I have set max_execution_time to 300 just in case, but didn't help.
I have set $debug = 2; but it didn't show me any error on the screen.
Using WAMPSERVER3 Apache 2.4.18 - PHP 5.6.19 - MySQL 5.7.11

Maybe I should try update from 1.92 to 2.05 and then from 2.05 to 2.51 ?

Thanks,
Marius.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #141383 par marius2
marius2 a répondu au sujet : Cannot update from 1.92+ to 2.51.3+
UPDATE: I've edited /application/config/config.php file and changed 'debug'=>2 and it started to work.
If I set back to 'debug'=>0, it gives same error:
Internal Server Error
CDbCommand failed to execute the SQL statement: SQLSTATE[42S22]: Column not found: 1054 Unknown column 't.allowjumps' in 'field list'
An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Strange... Maybe it's wamp and Windows OS problem...

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #141421 par jelo
jelo a répondu au sujet : Cannot update from 1.92+ to 2.51.3+
I would recommend to upgrade in smaller steps. From 1.92+ to 2.05/2.06 is already a huge step.
2.5X.X is another beast. I would use the latest from the 2.5X.X. to upgrade from 2.0X. Personally I wouldn't use 2.5.X currently at all.
Too many changes happening. But that is just my opinion.
At least make a copy to be able to use LS 2.0X (LTS) beside LS 2.5.X.X.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois - il y a 2 ans 1 mois #141438 par LouisGac
LouisGac a répondu au sujet : Cannot update from 1.92+ to 2.51.3+

jelo écrit: Personally I wouldn't use 2.5.X currently at all.
Too many changes happening. But that is just my opinion.


That's not true anymore. 2.5 is now very reliable and stable. Only some debug are pushed now. Indeed, today, 2.06 has more bug than 2.5, and not all the fixes have been ported to 2.06lts. We'll do it in the future, but keep in mind that 2.06lts has now more bugs than 2.5.

Big changes on templates HTML is planned, but they will be published in a new major version release.

So you'd rather update to 2.5.
Dernière édition: il y a 2 ans 1 mois par LouisGac.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #141497 par fvanderstarre
fvanderstarre a répondu au sujet : Cannot update from 1.92+ to 2.51.3+
The template incompatibility between 2.06 and 2.5 is keeping me from updating.
Are there any plans to incorporate a custom template migrating tool/script? That would be very helpful indeed!
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #141516 par LouisGac
LouisGac a répondu au sujet : Cannot update from 1.92+ to 2.51.3+

fvanderstarre écrit: Are there any plans to incorporate a custom template migrating tool/script?

No, nothing like that it planed. You can still contact a LimeSurvey partner to update your custom templates.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #141523 par fvanderstarre
fvanderstarre a répondu au sujet : Cannot update from 1.92+ to 2.51.3+
Hi Louis, I don't want to be nasty but there are just 13 bugs listed in the Bugtracker for version 2.06+ where status != 'closed'; for 2.50 and 2,51 combined the number is 51.
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 ans 1 mois #141528 par LouisGac
LouisGac a répondu au sujet : Cannot update from 1.92+ to 2.51.3+
many 2.06 bugs were closed after being fixed for 2.5 without being fixed for 2.06.

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!