Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : target="_blank" geht nicht

target="_blank" geht nicht il y a 2 mois 3 semaines #104087

  • Times
  • Portrait de Times
  • Hors ligne
  • Fresh Lemon
  • Messages : 15
  • Karma: 0
Version 2.05+ Build 140116
basic Template

Hallo zusammen,

ich versuche in den Bewertungsregeln eine Meldung anzuzeigen, in der ein Link auf eine externe Seite enthalten ist. Leider funktioniert die Funktion "anzeigen in neuem Fenster" nicht und zwar weder wenn ich es über das Symbol mache und den Link über das Frontend einfüge noch wenn ich direkt im Quelltext schreibe.
Wenn ich das reinschreibe und speichere, wird dieser Zusatz nicht gespeichert, sondern verschwindet im Nirvana. Beim nächsten Aufruf der entsprechenden Bewertungsregel ist von meinem target-Zusatz keine Spur mehr...

Weiß jemand Rat?

Vielen Dank und allen schon mal ein schönes Wochenende!
L'administrateur a désactivé l'accès en écriture pour le public.

target="_blank" geht nicht il y a 2 mois 2 semaines #104211

  • Times
  • Portrait de Times
  • Hors ligne
  • Fresh Lemon
  • Messages : 15
  • Karma: 0
Zwischenzeitlich habe ich festgestellt, dass innerhalb des <a> tags auch andere Anweisungen verschwinden... :ohmy:

Wogegen das <p> tag wie gewohnt mit html-Anweisungen umgehen kann.

Kann sowas an meinem System liegen oder ist das ein Bug?
L'administrateur a désactivé l'accès en écriture pour le public.

target="_blank" geht nicht il y a 2 mois 2 semaines #104258

  • Times
  • Portrait de Times
  • Hors ligne
  • Fresh Lemon
  • Messages : 15
  • Karma: 0
... und auch in der Willkommensnachricht verschwindet der Zusatz target="_blank"...

Es ist für die Umfrage natürlich wichtig, dass die Leute nicht gleich wieder weg sind. Kann man das irgendwie anders lösen?
L'administrateur a désactivé l'accès en écriture pour le public.

target="_blank" geht nicht il y a 2 mois 2 semaines #104262

  • holch
  • Portrait de holch
  • Hors ligne
  • LimeSurvey Team
  • Messages : 2441
  • Remerciements reçus 254
  • Karma: 94
Ich vermute dass hier der XSS Filter zuschlägt. Einfach mal in den Optionen ausschalten. Aber vorsicht, das erhöht natürlich das Risiko einer XSS Attacke.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
L'administrateur a désactivé l'accès en écriture pour le public.

target="_blank" geht nicht il y a 2 mois 2 semaines #104264

  • jonsen
  • Portrait de jonsen
  • Hors ligne
  • Senior Lime
  • Messages : 61
  • Remerciements reçus 2
  • Karma: 0
Versuche es doch einmal als Super-Admin, wenn möglich. Dieses Problem ist mir immer nur als normaler Benutzer untergekommen.

Es gibt einen Bug-Report unter bugs.limesurvey.org/view.php?id=8061
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: Times

target="_blank" geht nicht il y a 2 mois 2 semaines #104271

  • Times
  • Portrait de Times
  • Hors ligne
  • Fresh Lemon
  • Messages : 15
  • Karma: 0
@jonsen: super, das funktioniert tatsächlich!

UND: muss ich ab jetzt jedes Mal beim Ändern der Bewertungsregeln den Administrator bitten, weil es bei jedem Speichern von mir wieder verschwinden würde? Mag es grade nicht testen, mein Admin :evil: killt mich wenn ich ihm sage dass ich es sofort wieder zerschossen habe :blush:
L'administrateur a désactivé l'accès en écriture pour le public.

target="_blank" geht nicht il y a 2 mois 2 semaines #104272

  • Times
  • Portrait de Times
  • Hors ligne
  • Fresh Lemon
  • Messages : 15
  • Karma: 0
Ok, Frage beantwortet... ich muss... :(

Danke zusammen (auch wenn ich die XSS-Filter nicht ausprobiert habe, die Lösung mit dem Admin reicht mir)!
L'administrateur a désactivé l'accès en écriture pour le public.

target="_blank" geht nicht il y a 2 mois 2 semaines #104275

  • jonsen
  • Portrait de jonsen
  • Hors ligne
  • Senior Lime
  • Messages : 61
  • Remerciements reçus 2
  • Karma: 0
Ja genau, bei jedem Speichervorgang aufs neue! So macht man sich Freunde in der IT :D

Weitere Diskussion über das Problem sollte dann vielleicht im (englischsprachigen) Bug-Report stattfinden...
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.126 secondes
Donation Image