target="_blank" geht nicht

Plus d'informations
il y a 3 ans 5 mois #104087 par Times
Times a créé le sujet : target="_blank" geht nicht
Version 2.05+ Build 140116
basic Template

Hallo zusammen,

ich versuche in den Bewertungsregeln eine Meldung anzuzeigen, in der ein Link auf eine externe Seite enthalten ist. Leider funktioniert die Funktion "anzeigen in neuem Fenster" nicht und zwar weder wenn ich es über das Symbol mache und den Link über das Frontend einfüge noch wenn ich direkt im Quelltext schreibe.
Wenn ich das reinschreibe und speichere, wird dieser Zusatz nicht gespeichert, sondern verschwindet im Nirvana. Beim nächsten Aufruf der entsprechenden Bewertungsregel ist von meinem target-Zusatz keine Spur mehr...

Weiß jemand Rat?

Vielen Dank und allen schon mal ein schönes Wochenende!

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104211 par Times
Times a répondu au sujet : target="_blank" geht nicht
Zwischenzeitlich habe ich festgestellt, dass innerhalb des <a> tags auch andere Anweisungen verschwinden... :ohmy:

Wogegen das <p> tag wie gewohnt mit html-Anweisungen umgehen kann.

Kann sowas an meinem System liegen oder ist das ein Bug?

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104258 par Times
Times a répondu au sujet : target="_blank" geht nicht
... und auch in der Willkommensnachricht verschwindet der Zusatz target="_blank"...

Es ist für die Umfrage natürlich wichtig, dass die Leute nicht gleich wieder weg sind. Kann man das irgendwie anders lösen?

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104262 par holch
holch a répondu au sujet : target="_blank" geht nicht
Ich vermute dass hier der XSS Filter zuschlägt. Einfach mal in den Optionen ausschalten. Aber vorsicht, das erhöht natürlich das Risiko einer XSS Attacke.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104264 par jonsen
jonsen a répondu au sujet : target="_blank" geht nicht
Versuche es doch einmal als Super-Admin, wenn möglich. Dieses Problem ist mir immer nur als normaler Benutzer untergekommen.

Es gibt einen Bug-Report unter bugs.limesurvey.org/view.php?id=8061
Les utilisateur(s) suivant ont remercié: Times

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104271 par Times
Times a répondu au sujet : target="_blank" geht nicht
@jonsen: super, das funktioniert tatsächlich!

UND: muss ich ab jetzt jedes Mal beim Ändern der Bewertungsregeln den Administrator bitten, weil es bei jedem Speichern von mir wieder verschwinden würde? Mag es grade nicht testen, mein Admin :evil: killt mich wenn ich ihm sage dass ich es sofort wieder zerschossen habe :blush:

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104272 par Times
Times a répondu au sujet : target="_blank" geht nicht
Ok, Frage beantwortet... ich muss... :(

Danke zusammen (auch wenn ich die XSS-Filter nicht ausprobiert habe, die Lösung mit dem Admin reicht mir)!

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 5 mois #104275 par jonsen
jonsen a répondu au sujet : target="_blank" geht nicht
Ja genau, bei jedem Speichervorgang aufs neue! So macht man sich Freunde in der IT :D

Weitere Diskussion über das Problem sollte dann vielleicht im (englischsprachigen) Bug-Report stattfinden...

Connexion pour participer à la conversation.

Avez-vous déjà participé à notre enquête auprès des clients?

Ne manquez pas votre chance à des prix incroyables.

S'il vous plaît cliquez ici pour participer:

Commencer

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant