Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Erreur de sauvegarde des résultats

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104679

  • rodparis
  • Portrait de rodparis
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Karma: 2
Bonjour à tous,

J'ai de temps en temps des emails automatiques, de mon installation LS, qui m'arrivent et qui m'informent qu'il y a une erreur SQL d'enregistrement des résultats.

Voici le détail du mail :

Une erreur s’est produite pendant la sauvegarde d‘une réponse au questionnaire d’identifiant TOTO - 772736

DONNÉES A SAISIR:
token:
772736X214X621:
772736X214X622:
772736X214X626:
772736X214X623:
772736X214X624:
772736X214X625:
772736X214X636:
772736X205X606:
772736X205X607:
772736X211X617:
772736X212X618:
772736X216X638:
772736X217X637:
772736X206X608SQ001:
772736X207X609:
772736X207X616:
772736X207X610:
772736X208X611:
772736X215X627:
772736X213X619:
772736X213X620NOM:
772736X213X620PRENOM:
772736X213X620TEL:
772736X213X620EMAIL:
772736X213X620SOCIETE:

CODE SQL QUI A ÉCHOUÉ:


MESSAGE D’ERREUR:


Il n'y a strictement rien d'inscrit dans le message d'erreur.

Mon questionnaire est activé, pas de réponse anonyme, et j'enregistre Date et IP.

J'ai quand même pu remarquer que je reçois ce message pour tous les répondants qui ont une adresse IP avec 3 chiffres au début comme par exemple 123.123.123.123. Mais il y a bien des IP avec ce type de format qui passent sans soucis.
J'ai du mal à cerner le soucis.


Quelqu'un a t'il déjà eu le même pb ? Solution ?

Merci par avance.
Dernière édition: il y a 2 mois 1 semaine par rodparis. Raison: Ajout
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104680

  • Nickko
  • Portrait de Nickko
  • Hors ligne
  • LimeSurvey Team
  • Messages : 1929
  • Remerciements reçus 218
  • Karma: 44
J'ai eu ça une fois, le problème s'est résolu de lui même :-/
Peux-tu nous dire quelle version de LS tu utilises ?
Nickko
Ergonome / Usability expert
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104711

  • rodparis
  • Portrait de rodparis
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Karma: 2
Hello,

J'utilise la dernière version : Version 2.05+ Build 140131

J'ai est eu encore 3 aujourd'hui ! Je ne sais pas du tout d'où cela vient ! Et c'est galère car je perd des réponses !
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104712

  • rodparis
  • Portrait de rodparis
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Karma: 2
Cela se traduit par le fait que le questionnaire indique bien qu'il est complété mais seules les colonnes : Complété, ID de la réponse, Langue de départ, Date de lancement, Date de la dernière action, Adresse IP sont renseignés !
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104736

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 5850
  • Remerciements reçus 716
  • Karma: 222
Salut,

Sur d'autres réponses, ca passe bien ?
Dans ce cas, c'est étrange, maintenant il est possible que le serveur soit surchargé à ce moment là pour X raison.
Peux tu essayer de te renseigner chez ton hébergeur ?

Denis
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104790

  • rodparis
  • Portrait de rodparis
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Karma: 2
J'ai fait la vérif : Non 0 pic et à peine 15% de CPU consommé.
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104794

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 5850
  • Remerciements reçus 716
  • Karma: 222
Je vais jeter un coup d'oeil au code, c'est bizarre que tu n'est pas de retour plus "informatif".

Denis
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104802

  • rodparis
  • Portrait de rodparis
  • Hors ligne
  • Senior Lime
  • Messages : 40
  • Karma: 2
Oui et celà m'agace profondément !
Et ça ne le fait que depuis la version 2.05+ Build 140131 !
J'en ai de plus en plus et toujours rien de verbeux sur le message d'erreur !

Il n'y a pas une possibilité de mise en place de logs ou de traces ?
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 mois 1 semaine #104804

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 5850
  • Remerciements reçus 716
  • Karma: 222
Au cas ou, essaye avec debug>2 dans application/config.config.php ?

Denis
L'administrateur a désactivé l'accès en écriture pour le public.

Erreur de sauvegarde des résultats il y a 2 jours 8 heures #107606

  • tamacheq
  • Portrait de tamacheq
  • Hors ligne
  • Junior Lime
  • Messages : 22
  • Karma: 0
Bonjour
Je rencontre également ce problème depuis cette semaine, je n'ai pas installé de nouvelle version depuis l'été dernier, donc je suis sous Debian avec la version 2.00+ Build 130708
L'erreur se produit parfois au moment de l'enregistrement de l'invitation, parfois au moment de l'enregistrement des données.
La machine n'héberge que ce service donc n'est pas surchargée. Nous avons plusieurs questionnaires accessibles et le problème ne se pose que sur un des questionnaires.
Je ne rencontre pas ce problème sur le serveur de développement qui contient la même version de limesurvey avec une copie du questionnaire de la prod.
Merci pour toute suggestion (j'ai activé le mode debug en attendant)
Anne
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: Nickko
Temps de génération de la page : 0.149 secondes
Donation Image