Questionnaire complété dans les réponses, mais pas dans les invitations

Plus d'informations
il y a 4 ans 7 mois - il y a 4 ans 7 mois #95955 par darknico84
darknico84 a créé le sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Bonjour,

J'utilise actuellement Limesurvey Version 2.00+ Build 130325 et je viens de me rendre compte d'un phénomène étrange au moment d'une relance de questionnaire. En effet, alors que certaines personnes avaient complété leur questionnaire (complete=Y dans la fenêtre d'analyse des réponses), le paramètre de complétude apparaît à N dans l'écran de gestion des invitation et de ce fait les relances sont renvoyées même aux personnes qui ont déjà rempli le questionnaire.

Avez vous déjà été confronté à ce problème ? un workaround existe-t-il ?

Merci d'avance pour vos retour d'expérience

Cordialement,

Nicolas
Dernière édition: il y a 4 ans 7 mois par darknico84.

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois #95962 par Nickko
Nickko a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Tu entends quoi par relance ?

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois #95966 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
par relance je veux dire "Envoyer un courrier de rappel"

Cordialement,

Nicolas

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois #95971 par Nickko
Nickko a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Hum, alors je ne vois pas. Es-tu sur qu'il ont été jusqu'à la fin du questionnaire ?

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois #95973 par DenisChenu
DenisChenu a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Pas de changement des code d'invitations entre 2 ?

As tu accès à la base des questionnaires ? Il y a eu un bug temporaire durant 1 semaine qui créé des colonnes à 5 caractères pour les token de la table des réponses, peut être est ce lié.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois #95980 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Donc non il n'y a pas eu de changement de code d'invitation, les personne ont bien complété les questionnaires (complete=Y).
Concernant les tables tu parles de lime_answers ou les tables lime_tokens_xxxxxx. Sur les dernières le champ token est un varchar(35).

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois - il y a 4 ans 7 mois #96001 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Par contre chose étrange si j'essaye de de modifier le statut complété dans l'écran d'invitation, dans un premier temps la valeur est acceptée mais si je rafraichis la page, la valeur repasse à N. Apparemment la valeur n'est pas sauvegardée en base de données.

J'ai upgradé limesurvey en Version 2.00+ Build 130514

Y-a-t'il un moyen de passer l'application en "mode debug" avec logs renseignées dans un fichier donné ?

Merci d'avance pour votre aide
Dernière édition: il y a 4 ans 7 mois par darknico84.

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois #96009 par DenisChenu
DenisChenu a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Salut,

application/config/config.php
'debug'=>2

Et au cas ou, avec firebug: 'debugsql'=>1


As tu pu vérifier le type des colonnes de la table des réponses ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 7 mois - il y a 4 ans 7 mois #96029 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Merci beaucoup pour les infos de debug je vais tester cela immédiatement. On dirait que le champ completed de la table lime_tokens_numerodesquestionnaire n'est pas mis à jour en fin de questionnaire.

Pour la "table des réponses" de quoi s'agit-il ? de la table lime_answer , de lime_tokens_numérodequestionnaire ou de lime_survey_numérodequestionnaire ?



J'ai testé le mode debug ... et je n'ai absolument rien "d'anormal" ...


Pour Information j'ai exporté un questionnaire et l'ai importé (à l'arrache ) dans une autre installation de lime survey (dans la même version) et là ça fonctionne .... le problème semble donc lié à mon installation de limesurvey (se pose alors à moi le douloureux problème de la migration d'enquêtes actuellement en ligne/production :( si je n'arrive pas à "réparer")
Dernière édition: il y a 4 ans 7 mois par darknico84.

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 6 mois - il y a 4 ans 6 mois #96095 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Dans la série des tests non concluants, j'ai réalisé une installation from scratch de limesurvey et utilisé une copie de la base de données actuellement en production. Avec ce test je reproduis le problème. Le soucis semble donc lié à la structure de la base de données.



Il semblerait que le problème apparaisse quand j'importe une liste d'invitation depuis un fichier csv ... si je crée les invitations une à une part l'interface de limesurvey tout fonctionne correctement. Une idée d'où cela pourrait venir ?


Il semblerait que si en fin d'enquête le champ "uses left" est supérieur à 0 alors le champs completed n'est pas modifié.
Dernière édition: il y a 4 ans 6 mois par darknico84.

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 6 mois #96102 par DenisChenu
DenisChenu a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Salut,

Pourrait tu faire un rapport de bug pour que le problème soit réglé ?

Merci

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion pour participer à la conversation.

Plus d'informations
il y a 4 ans 6 mois #96109 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Pas de problème je fais ça dans la journée.

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 10 mois #103761 par Jean1234
Jean1234 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Bonjour Darknico 84 et DenisChenu,

J'ai le même problème depuis quelques jours.

Aviez-vous trouvé le problème et si oui, quelle était la solution?

Cordialement

Jean

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 10 mois #103763 par darknico84
darknico84 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Salut Jean1234,

Est-ce que par hasard tu aurais un useleft > 1 ? En ce qui me concerne j'avais un useleft ( qui est décrémenté de 1 à chaque réponse) largement supérieur à un et tant que ce champs n'était pas à 0 l'utilisateur n'était pas considéré comme ayant répondu et fini son questionnaire.
Mon workaround a été de positionner ce useleft à 1, et chaque fois que je devait relancer tout le questionnaire (c'était un questionnaire qui devait être répété tous les mois pendant 9 mois), je remettait le champs useleft à 1 au moment de chaque nouvelle campagne.

En espérant que ça puisse t'aider

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 10 mois #103764 par Jean1234
Jean1234 a répondu au sujet : Questionnaire complété dans les réponses, mais pas dans les invitations
Salut Darknico84,

Je vais essayer cette solution. Excuse ma question de novice mais ou se trouve le parametre pour mettre useleft a 1 s'il te plait?

Merci a l'avance

Connexion pour participer à la conversation.

Modérateurs: Nickko

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!