{SGQ} variable non définie

Plus d'informations
il y a 7 mois 6 jours #171006 par Tib
COM_KUNENA_MESSAGE_CREATED_NEW
Bonjour,

J'ai migré d'une version 2.05 vers une version 3.13;
La variable {SGQ} que j'utilisais dans la vieille version me retourne maintenant "...Variable non définie..."

Que faut-il utiliser à la place avec la nouvelle version ?
Par avance, merci.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 6 jours #171012 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
Tente avec {self.SGQA} MAIS : {SGQ} est très utilisé pour le javascript : rapporte le bogue (cela fonctionnait aussi sur 2.73).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 6 jours #171016 par Tib
COM_KUNENA_MESSAGE_REPLIED_NEW
idem avec {self.SGQA}
ça me parait gros quand même comme bug.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 6 jours #171024 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
A zutre, {self.SGQA} c'est un gros gros bug …

Tu l'utilise ou {SGQ}
Parceque normalement il est là : github.com/LimeSurvey/LimeSurvey/blob/b0...ntimeHelper.php#L372

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 5 jours #171044 par Tib
COM_KUNENA_MESSAGE_REPLIED_NEW
de manière assez basique dans le code source d'un libellé de question

<script type="text/javascript" charset="utf-8">
alert ({self.SGQA});
</script>

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 5 jours #171051 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
OK,
Désolé, je me suis gourré sur le code : c'est
{self.SGQA}
s g q a en minuscule.

Le plus simple : fait un questionnaire avec 1 questions.

Avec comme texte :
SGQ : {SGQ} <br>
self.sgqa : {self.sgqa}}
Mais chez moi : ça passe.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 5 jours #171061 par Tib
COM_KUNENA_MESSAGE_REPLIED_NEW
Je viens de comprendre...
En fait le code suivant fonctionne si on le positionne dans le texte de la question mais pas dans l'aide... avant cela fonctionnait.
SGQ : {SGQ}<br />
<script type="text/javascript" charset="utf-8">  
  alert ("{SGQ}")
</script>

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 7 mois 5 jours - il y a 7 mois 5 jours #171062 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
Donc : tu peux rapporter le bogue dans ce sens :).

Peut être pas pour la 3 puisque {self.SGQA} devrait fonctionner dans l'aide (SGQA en minuscule)

Mais sinon : tu peux utiliser gitlab.com/SondagesPro/addScriptToQuestion pour les scripts. Ca ajoute un paramètre avancé juste pour ton script.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last edit: il y a 7 mois 5 jours by DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Modérateurs: Nickko

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!