[Résolu] premier questionnaire : blocage sur création table des réponses

Plus d'informations
il y a 9 mois 3 semaines - il y a 9 mois 2 semaines #151997 par arborepom
arborepom a créé le sujet : [Résolu] premier questionnaire : blocage sur création table des réponses
Bonjour à tous,
je découvre, je débute ... et je bloque ... déjà :-((

installation sur un serveur qui héberge notre blog, nos mails, etc ... ( INFINI )
de la Version 2.64.3+170327

Lorsque je demande à activer mon questionnaire (qui ne contient qu'une seule question ; zone de texte court avec carte openstreetmap) il m'est aimablement répondu :

"table des réponses au questionnaire n'a pas pu être créée. Habituellement, ceci est causé par le fait d'avoir trop de (sous-) questions dans le questionnaire. Veuillez essayer de retirer des questions de votre questionnaire."

Il y a sans doute une autre explication ... si je peux avoir un p'tit coup de main ce serait sympa ;)
Merci

ps : peut-être / sans doute rien à voir mais pour l'install il m'a fallu modifier dans ./installer/sql/create-mysql.sql le moteur mysql qui était "MYISAM" à "InnoDB" pour que ça corresponde à ce qui est installé chez Infini.
Dernière édition: il y a 9 mois 2 semaines par Nickko.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines #151998 par Nickko
Nickko a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Hum... tu n'as pas du tout MyISAM chez infini ?
Souvent, on a le choix de plusieurs moteurs avec MySQL. Peut-être que ça n'a rien à voir mais compte tenu des informations que tu nous donnes, c'est pas là que je commencerais.

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines - il y a 9 mois 3 semaines #152002 par arborepom
arborepom a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Bonjour Nickko, merci de m'avoir répondu.
Non, non plus MyISAM ils sont passés sur à InnoDB ...
(mais l'install s'est faite sans erreurs indiquées après la modif que j'ai indiqué en ps )

Il y aurait un autre fichier à modifier tu penses ?
merci
Dernière édition: il y a 9 mois 3 semaines par Nickko.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines #152007 par Nickko
Nickko a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Aucune idée, il faudrait attendre le passage de quelqu'un de plus expérimenté que moi.

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines - il y a 9 mois 3 semaines #152009 par arborepom
arborepom a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Merci bien toujours Nickko :-)
Oui, oui : je sais/vais patienter ;)
@+
Dernière édition: il y a 9 mois 3 semaines par Nickko.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 3 semaines #152054 par DenisChenu
DenisChenu a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Oui, on créé les BDDs questionnaire en myisam.

infini le propose pas ????? change d'hébergeur.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152058 par arborepom
arborepom a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Bonjour tout le monde et merci pour cette réponse Denis ... même si pour le moment je reste bloqué au même stade car ...

DenisChenu écrit: Oui, on créé les BDDs questionnaire en myisam.

infini le propose pas ????? change d'hébergeur.


... je ne vois pas la vie ainsi !


1/Je ne discuterai pas des choix de mon hébergeur : je n'en ai absolument pas le niveau technique pour le faire.
2/je ne changerai pas d'hébergeur et n'ai pas à me justifier sur ce point.
3/je pars du principe qu'il y a toujours une solution ... plutôt que des problèmes.
4/en modifiant très légèrement le fichier limesurvey/installer/sql/create-mysql.sql j'ai réussi à faire l'install ... donc c'est un bon début je trouve :-))

Question : puisque, en préambule, j'ai précisé ne pas avoir un niveau technique suffisant je me dis qu'il reste peut-être une ou plusieurs autres modifs à faire du fait de ce moteur InnoDB retenu sur la nouvelle plateforme de mon hébergeur ?

Mais il est fortement possible que je me plante ... et que mon problème provienne d'autre chose ?


Merci de m'aider à aller ... de l'avant ;)

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152061 par arborepom
arborepom a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Bonjour,

1 question puis 1 réponse ; je commence par la question :

Comment placer ce fil en mode [Résolu] ?
(à moins que ça ne fasse pas partie de mes attributions mais de celles des modérateurs )

Et je poursuis par la méthode qui m'a permis de résoudre mon problème (Si ça peut servir un autre débutant de mon genre;)
Remarque : et comme j'ai très peu de mémoire je serai peut-être le premier à réutiliser ce "mode d'emploi" !

Pour que Limesurvey puisse fonctionner avec le moteur InnoDB il y a deux fichiers à modifier :
a) limesurvey/installer/sql/create-mysql.sql
b) limesurvey/application/core/db/MysqlSchema.php

Dans ces 2 fichiers il faut et il suffit de remplacer MyISAM par InnoDB


Merci aux foromeux actifs et francophones qui ont participé à ce fil : si je n'ai pas eu la réponse complète ça m'a motivé pour persévérer :-))

Voili, voilà ; à bientôt (bin oui, je débute avec Limesurvey ... donc les soucis devraient se suivre sans se ressembler ! )
@+
Phil


ps : c'est pratique de pouvoir communiquer avec les techs bénévoles de son hébergeur associatif -et d'être dépanné- un samedi après-midi grâce à l'irc :-))

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152107 par Nickko
Nickko a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Pour marquer le sujet comme lu, il suffit d'éditer le titre du premier message.
Je l'ai fait pour toi.

Merci d'avoir indiqué comment résoudre le problème.
Juste un point à garder à l'esprit, il faudra appliquer la modification à chaque mise-à-jour de Limesurvey.

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152120 par arborepom
arborepom a répondu au sujet : premier questionnaire : blocage sur création table des réponses
> il suffit d'éditer le titre du premier message
encore qqchose de simple ... qui m'a échappé : merci !

>Juste un point à garder à l'esprit, il faudra appliquer la modification à chaque mise-à-jour
Oui et ...
a) c'est vrai : il aurait été judicieux que je le précise ;)
b)on pourrait aussi imaginer que Limesurvey n'impose pas MyISAM mais propose un choix lors de l'install

@+

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152123 par Nickko
Nickko a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Tu peux le proposer, dans le menu en haut de la page, menu "community" / "feature request". Voir même si la demande a déjà été introduite, tu peux voter pour.

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152133 par arborepom
arborepom a répondu au sujet : premier questionnaire : blocage sur création table des réponses
Je ne dois pas être bien finot car je ne comprends pas comment l'utiliser !

il est dit "If you want to submit a feature request please use the category 'Feature requests' in the upper right select box - or use the link ideas.limesurvey.org ." ... mais quand je clique sur 'Feature requests' j'ai l'impression qu'il ne sepasse rien ; en fait j'ai la sensation de ne pas quitter le rapporteur de bogues ...

Connexion pour participer à la conversation.

Plus d'informations
il y a 9 mois 2 semaines #152135 par Nickko
Nickko a répondu au sujet : premier questionnaire : blocage sur création table des réponses
En fait, le rapporteur de bug est aussi utilisé pour les features requests. Ajouter un bug dans le projet feature request pour suggérer une nouvelle fonctionnalité.

Nickko
Head of ergonomics, UX & UI.

Connexion pour participer à la conversation.

Modérateurs: Nickko

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!