underscores: Porting 1.9+ LS to 2.6+ LS

Plus d'informations
il y a 2 mois 1 semaine #158592 par ucsd_brownlab
ucsd_brownlab a créé le sujet : underscores: Porting 1.9+ LS to 2.6+ LS
I read some older discussions related to the loss of underscores in items codes (variable names).

We are looking for suggestions on how we might convert our 1.92+ surveys to 2.67+.

We have thousands of items and most have some relevance coding. A large proportion of items have field names (codes) that include underscores. We have lots of items that might be named something like "Demo1_1" which are converted to "Demo11" if the underscore is simply dropped, but we already have items that are named "Demo11."


Looks like there are tags in the .lss files with underscores, so it looks like we can't just do a global replace of the underscores with some alpha characters.

Any suggestions?

Connexion pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #158613 par LouisGac
LouisGac a répondu au sujet : underscores: Porting 1.9+ LS to 2.6+ LS
If I had to do something like that, I would not use a lss search and replace, but I'd write a PHP script using the db entries.

Connexion pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #158624 par DenisChenu
DenisChenu a répondu au sujet : underscores: Porting 1.9+ LS to 2.6+ LS
Else : when updating from 1.9+ to 2.6+ : old survey question code are not updated.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!