Japanese language is not displaying correctly when png is generated

Plus d'informations
il y a 3 ans 9 mois #100991 par skye
skye a créé le sujet : Japanese language is not displaying correctly when png is generated
I have a problem when I try to do responses and statistics in japanese then view the statistics using pdf/html. The PNG that was generated does not have correct japanese language. I can see squares instead of japanese. Please help.

Is this a bug?

Thanks.
Pièces jointes :

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 9 mois #100992 par c_schmitz
c_schmitz a répondu au sujet : Japanese language is not displaying correctly when png is generated
Assuming that you are using the latest 2.0 version:

For package size reasons the migmix-1p-regular.ttf font to show Japanese characters in the statistics graphs is not included with LimeSurvey.

Please download it from mix-mplus-ipa.sourceforge.jp/migmix/ ,
unzip and put the migmix-1p-regular.ttf file into the /fonts directory of your LimeSurvey installation.

Best regards

Carsten Schmitz
LimeSurvey project leader
Les utilisateur(s) suivant ont remercié: skye

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 9 mois #101000 par DenisChenu
DenisChenu a répondu au sujet : Japanese language is not displaying correctly when png is generated
Yes,

And it's explain here :
github.com/LimeSurvey/LimeSurvey/blob/ma...-%20Japanese.ttf.txt

For information (mine), PDF use cid0jp font from tcpdf : did PDF are OK ?

And another think : to Carsten : i think we put an alert if there are font file in text but no fonts : maybe this a bug (little).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Les utilisateur(s) suivant ont remercié: skye

Connexion pour participer à la conversation.

Plus d'informations
il y a 3 ans 9 mois #101011 par skye
skye a répondu au sujet : Japanese language is not displaying correctly when png is generated
thank you for your answers. I tried it and it worked.

Connexion pour participer à la conversation.

Avez-vous déjà participé à notre enquête auprès des clients?

Ne manquez pas votre chance à des prix incroyables.

S'il vous plaît cliquez ici pour participer:

Commencer

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant