Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi

SUJET : Antiquated version not using translation file

Antiquated version not using translation file il y a 9 mois 1 semaine #97742

  • chauchse
  • Portrait de chauchse
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
Hello,

We are using version 1.82+ (6825). I know, I know, plans are in the works to upgrade.

Multilingual surveys and surveys set up with a base language other than the system default are not fully translated. The questions, labels and answers are all fine - other lanfguages are displayed as expected. It is the "infrastructure" that is not translated: the previous/next buttons, the "No Answer" label, the Note on Privacy etc.

It's as though Limesurvey is not recognizing the locale or translation file for some reason. The required locale (fr) is set up. I've tried placing updated fr.mo and fr.po files in /locale/fr/LC_MESSAGES.

French appears to be supported in /classes/core/surveytranslator.php:
// French
            $supportedLanguages['fr']['description'] = $clang->gT('French');
            $supportedLanguages['fr']['nativedescription'] = 'Français';
            $supportedLanguages['fr']['rtl'] = false;

Suggestions?
Dernière édition: il y a 9 mois 1 semaine par DenisChenu. Raison: code again
L'administrateur a désactivé l'accès en écriture pour le public.

Antiquated version not using translation file il y a 9 mois 1 semaine #97754

  • DenisChenu
  • Portrait de DenisChenu
  • Hors ligne
  • Moderator Lime
  • Messages : 5840
  • Remerciements reçus 714
  • Karma: 222
Salut,

Think french have good support on this version : no need to update fr.po and .mo.

But look at config-default if you don't have something for langage error.

Denis
L'administrateur a désactivé l'accès en écriture pour le public.
Cet utilisateur a été remercié pour son message par: chauchse

Antiquated version not using translation file il y a 9 mois 1 semaine #97763

  • chauchse
  • Portrait de chauchse
  • Hors ligne
  • Fresh Lemon
  • Messages : 3
  • Karma: 0
Salut Denis,

I flipped the $translationmode parameter in config-defaults.php and that did the trick!

Merci beaucoup!
L'administrateur a désactivé l'accès en écriture pour le public.
Modérateurs: ITEd
Temps de génération de la page : 0.186 secondes
Donation Image