Issue when using the same access token twice

Plus d'informations
il y a 1 mois 4 jours #187783 par roseplasticHR
Hello together,

we want to make a survey for our employees. We are using the hosted version by LimeSurvey and use a Kiosk mode, as the PC´s are placed in a public location.

To ensure that every employee can only access the survey one time, everone gets one access token.

So far this works good, but when someone tries to use the same token twice, it opens the following page where the user gets stuck because he has no navigation options in the browser (since we use Kiosk mode to only access the survey).




If I enter a wrong token, I get the message I´d expected to also get when using the token a second time.



How can I change the behaviour, so that the message always shows up like in the second screenshot?
The text message in the second screenshot already tells "Wrong token or token was already used".

Thanks!
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 1 mois 4 jours #187812 par jelo
To me LimeSurvey is not ready for Kisokmode usage.

If you use a browser with Kioskmode, a watchdog feature might be available to reset the survey from time to time.

You should submit a bugreport to point out the dead ends for navigation without browser support.

The only thing you might can do, is to place links via the theme pages to start the survey again. Look for token.twig

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Les utilisateur(s) suivant ont remercié: roseplasticHR

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 jours #187818 par holch
And to be honest, the case with tokens for kiosk mode is relatively rare, which is why probably no one yet noticed this issue.

Usually in kiosk mode people have no token and just access the survey openly. Usually when there is a token, people will access the survey from their device, not via a public computer, in kiosk mode.

So these are the "normal" scenarios and now we have a different scenario that doesn't fit into "normal" and you run into problems.

What I don't understand is why there are different error screens, especially as one of them doesn't seem to be included into the theme, has no theme design.

So I agree with Jelo, you should create a bug report.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Les utilisateur(s) suivant ont remercié: DenisChenu, roseplasticHR

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 jours #187821 par roseplasticHR
Thanks so far! I created a bug report...

Hopefully this case will happen very rarely while the time of the survey being taken. If we face this problem, the user can hit "CTRL+ALT+DEL" to get back to the survey start page.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 jours #187823 par jelo

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!