Problems with Lime Survey 2.00+ Build 130526

Plus d'informations
il y a 1 mois 5 jours #185534 par sbaersch
Dear Community,

I am struggling with the 2.00+ Build 130526 Versions of Limesurvey. My problem is, I add pictures in the text-elements and save the uploaded pictures (Step2). But I cannot see the picture in the preview. Has anyone a solution for the problem? Do I miss any step?

See also the pictures: Step1 upload the picture, Step2 : the picture is there Step3: no picture anymore.

I know this is a very old version but is the university version.

Best

Sören
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 1 mois 5 jours #185535 par holch
It is pretty difficult to help with a version that is so old and also not the latest update of this branch (2.06 LTS). This is over 6 years old and there has been another major release (2.7x) between the branch your university runs and the current stable release (3.x). And 4.x is already in beta stage and shall be released in the next couple of months. So basically your university is running Windows 95. I think especially with GDPR/DSVGO in mind it is quite "fahrlässig" (negligent) of your university to not run any updates for over 6 years now. I am not even talking about upgrading to newer branches, but just running security updates and bug fixes for the same branch (Denis still maintains a fork of this LS branch and tries to keep it secure...).
*rant over*

I can see one picture there, so it seems to work for some pictures, right?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 5 jours #185536 par sbaersch
Dear Holch,

I'm absolute with you regarding the data issue! This is a problem. Yes, I can upload pictures but, when I want to check the preview (Step3) the picture is not there anymore. When I click back to the text-element they picture is also gone.

Best

Sören

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 5 jours #185538 par holch
Hmmmm, this might be a case of the XSS-Filter in Action (which you probably can't switch off). Not sure if the XSS-Filter filters images, because I don't really use it.

What happens if you include a normal hyperlink?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 5 jours - il y a 1 mois 5 jours #185541 par Joffm
Hi, Sören,
what you show us in step3.png is not a preview. Seems to be the GUI.
Here you will never see pictures.

Please show us the "Welcome"-page where you obviously want to display it.
Here a very quick example in Version 2.06+ Build 160129. (and default-template)
Don't care about the picture. There was no other available.

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Pièces jointes :
Dernière édition: il y a 1 mois 5 jours par Joffm.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 5 jours #185543 par sbaersch
Thank you.

I will try it!

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 5 jours - il y a 1 mois 5 jours #185544 par sbaersch
Hey Joffm,

thank you for the reply!

Here the preview.

Best Regards
Pièces jointes :
Dernière édition: il y a 1 mois 5 jours par sbaersch.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 5 jours #185545 par holch
Looking at the preview, you seem to have more problems, because the logo is also not shown...

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 jours #185586 par sbaersch
Hello Holch,

I tried with a hyperlink, especially with <img src= but it still does not work.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 jours #185590 par tpartner
Can you give a link to a live sample survey?

Switch the editor to source mode ensure that the src path is correct.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!