rendering question with "grand total" takes (too/very) long

Plus d'informations
il y a 3 mois 1 semaine #182968 par silverlime
Dear forum-members and limesurvey-team,

we have a problem with the following question-type

* Array (Texts) and
** show totals row&columns
** show grand total

The rendering of such a question takes several seconds in lime-survey 3.X whereas the same question loads almost instantly in lime-survey 2.x. My guess is, that something has changed in the way the rendering is processed (in qanda_helper.php ?). I would appreciate if anyone had a hint or solution.

We tested it with all versions of limesurvey up to the current. It is also reproducible in the Online Demo-version of limesurey. Steps to reproduce:
* create a question as Array (Texts)
* add e.g. 3 columns (X-Scale) an 15 rows (Y-Scale)
* In Question-Settings "Other"
** set "show totals for: Row&columns" and "Show grand total"
** set "only numbers"

Thank you in advance

Axel

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 3 mois 1 semaine #182987 par DenisChenu
Can you send a sample lss ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #182997 par silverlime
hi denis,

thank you ! i added the lss-file which i exported from the official online-Demo of limesurvey

best regards

axel
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine - il y a 3 mois 1 semaine #183000 par DenisChenu
I can not compare with 2.73, but when checking don't see real difference between 2.6lts and 3.X
on a 2.6lts
on a 3.X without ajax mode

Same (old) server for the 2

Loading:




But right , seems performance is better when updating for 2.6 than 3.X

Did you try without ajax mode ? I always diable ajax mode (and use a theme without ajax mode).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Pièces jointes :
Dernière édition: il y a 3 mois 1 semaine par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #183003 par silverlime
... thanks !

ajax on/off in template doesn't seem to make a difference. i tested both links (on mac os)


* demonstration.sondages.pro/135149
** safari: about 2 sec.
** firefox: about 2 sec.

* Demo.sondages.pro/135149
** safari: about 33 sec. !
** firefox: about 7 sec.

in which browser did you test? can you reproduce the above times on firefox/safari?

best regards

axel

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine - il y a 3 mois 1 semaine #183018 par DenisChenu
On firefox … don't have such difference … I check with reload current page…
Maybe some difference due to server too …

But right : if you can report (with your own server please) it can be great.

PS : i don't have a Safari box : since safari is not Free

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Dernière édition: il y a 3 mois 1 semaine par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #183019 par DenisChenu
PS : ifg you can send a video with Safari : it's best :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #183021 par silverlime
can't upload mov-file > would you mind to send me your mailaddress?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #183023 par holch
How about uploading to something like Dropbox and send the link here? No one really wants videos via email.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #183026 par jelo
This issue is not server related. It's not network related. It's browser related.
It took 32.34 s in Chrome Version 73.0.3683.103 (Official Build) (32-bit)

The long delay is mostly caused by a lot of forced reflows.



You might find delays in array filtering / ranking filtering too.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Pièces jointes :
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine - il y a 3 mois 1 semaine #183027 par silverlime
Dernière édition: il y a 3 mois 1 semaine par silverlime.
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine - il y a 3 mois 1 semaine #183050 par DenisChenu
Like i say : for reporting an issue

1. Use your own server (or the your limesurvey GMBH account server)
2. Use an included theme (the default or vanilla)
3. If you can use a video recorder : obsproject.com/ for example BUT developper tool can be sufficient
4. If you can use a 2.73 version
5. Make a survey without grandtotal and same screenshot or screenrecorder

But most important (even if you can do none of the previous part) : www.limesurvey.org/community/bug-tracker

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Dernière édition: il y a 3 mois 1 semaine par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine - il y a 3 mois 1 semaine #183059 par jelo

DenisChenu écrit: Like i say : for reporting an issue

Why all the videos and own server, generic theme requirements? It's a JavaScript issue (recalculating style, reapplying style, CPU till 100%). Or the survey file itself contains something.

I can reproduce that issue (testsurvey via Demo.sondages.pro/135149 ) in
Firefox and Chrome (both Windows 7 64bit) as well.





LimeSurvey will need to start pushing updates via different tiers. The take it or leave it approach will render installations useless for productive work. And debugging bugs become more difficult, because so many commits are released at once.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Pièces jointes :
Dernière édition: il y a 3 mois 1 semaine par jelo.
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine - il y a 3 mois 1 semaine #183062 par DenisChenu
1. my Demo website is on a old server (more than 11 years of services)
2. my Demo link didn't use a core template (myu template have a lot of JS too , can disable but …)

Then LimeSurvey GMBH can always say it's my server or my template … and don't fix the issue.

I think the best way is to use LimeSurvey GMBH server, but here we need to have a «it's better before» …
You can use my 2.6lts for it's better before, but for 3.X issue : use a clean setup on a clean server, OR limesurvey GMBH server (not Demo because Demo is wiped ech night).

You can use shnoulle.limequery.com/135149?newtest=Y&lang=en for reporting.

PS : strangely : i don't have such big issue on Firefox/Linux or Chromium/Linux : linux POWA \o/

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Dernière édition: il y a 3 mois 1 semaine par DenisChenu. Raison: PS

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 mois 1 semaine #183065 par jelo
A test with Demo.limesurvey.org show the same issues with the LSS export provided.




The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!