Question index issues

Plus d'informations
il y a 2 mois 1 semaine #180076 par marmo91
COM_KUNENA_MESSAGE_CREATED_NEW
Hello everyone, I created a survey with the following features:

-Questions index setted on FULL
-Groups of questions visible based on user attributes
-Displaying questions for groups



When a user accesses the survey, initially displays all groups in the index, advancing in the compilation, the index is filtered showing only the groups of questions accessible to the user.

How can I view only the correct groups in the index from the beginning?

Thank you all

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 2 mois 1 semaine #180077 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
Maybe (unsure)

Add a group at 1st position with only an hidden question.

The index part is tested after survey creation at the same time displaying 1st group. Then maybe ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 1 semaine #180090 par marmo91
COM_KUNENA_MESSAGE_REPLIED_NEW
Hi, I've executed your instructions, but the problem persists.

Would it be possible to retrieve the list of groups visible to the current user through some javascript function? and then hide the elements with a script added in the theme?

Thank you

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!