Group title not showing expression manager expression

Plus d'informations
il y a 2 mois 5 jours #168885 par bruce78
bruce78 a créé le sujet : Group title not showing expression manager expression
I have a group title that doesn't pick up an Expression Manager expression, even though questions within the group do...

I'm a bit puzzled as to why this is happening. I've just upgraded LS from 2.7.3 to 3.7.3 and everything else seems to be working fine after a few quick tests. Even more puzzling is that a test version of LS, also running 3.7.3 doesn't have this problem.

Here's a screenshot of the error when completing the survey.




Here's the group title that corresponds to the question on screen.



And here's the question text that is also shown on screen.

You'll see that the expression manager parses the {thebrandhidden.shown} variable without any problems.




I'm trying to think what might be causing the problem? Does anyone have any thoughts?
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 5 jours - il y a 2 mois 5 jours #168887 par DenisChenu
DenisChenu a répondu au sujet : Group title not showing expression manager expression
Can you control the file group_name.twig in your theme ?

Before this fix : group name are not Expression «compatible»

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Dernière édition: il y a 2 mois 5 jours par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 5 jours #168898 par bruce78
bruce78 a répondu au sujet : Group title not showing expression manager expression

DenisChenu écrit: Can you control the file group_name.twig in your theme ?


Yes, I can edit this file on the server, will that give me a solution?

DenisChenu écrit: Before this fix : group name are not Expression «compatible»


I've got a test install of LS running 3.7.3 which does show an Expression in the group name though? https://go.brandreflections.com/xus71This link will give you an example.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 5 jours #168899 par bruce78
bruce78 a répondu au sujet : Group title not showing expression manager expression
Ok, I've fixed this by copying over the files from the other LS installation and it's now working fine...

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 5 jours - il y a 2 mois 5 jours #168901 par DenisChenu
DenisChenu a répondu au sujet : Group title not showing expression manager expression
You use own theme ? And updated this file ?

Because the fix if since 3.6.2.

If you are on up to 3.6.2, and the file is in the LimeSurvey theme directory , maybe have this issue : bugs.limesurvey.org/view.php?id=13679

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Dernière édition: il y a 2 mois 5 jours par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 2 mois 4 jours #168907 par bruce78
bruce78 a répondu au sujet : Group title not showing expression manager expression
I'm on 3.7.3 using default bootswatch, I've not manually changed any of the files/themes...

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!