Syntax error or access violation: 1064

Plus d'informations
il y a 1 mois 4 semaines #186919 par molungus
Hi,

all of a sudden my surveys don't work anymore and the participants get the following error:

Interner Serverfehler
CDbCommand konnte das SQL-Statement nicht ausführen: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups WHERE questions.gid=groups.gid AND questions.sid=462472 AND questions.l' at line 1

Any idea what's going wrong and how to solve this?

Thanks in advance!

Thomas

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 1 mois 4 semaines #186921 par LouisGac
how did you update?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #186942 par molungus
Hi Louis,

Thank you for your reply and sorry for not sharing the information of my version.

The version is 2.73.0+171219. The installation is hosted by our university computing centre and I suspect there hasn't been an update for a long time :/

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines - il y a 1 mois 4 semaines #186954 par LouisGac
Hi, I'd suggest you export your survey in lss or lsa format, and upload it here in a free installation. If it fails again: it's a problem with the survey itself.
Dernière édition: il y a 1 mois 4 semaines par LouisGac.
Les utilisateur(s) suivant ont remercié: cdorin

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #186956 par molungus
Thanks again. The imported survey (lsa) works.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #186957 par LouisGac
So I would suggest you import again the survey in your LimeSurvey installation, without deleting the buggy one.

It will generate new ids for surveys, questions and groups, and could solve your problem.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #186958 par molungus
Unfortunately I immediately get the same error message when I try to import the survey. I just noticed that I get this error message when I click on any survey in my survey list.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines #186962 par LouisGac
so it's clearly a problem on your server side. You should contact your sysadmin to ask him if they recently changed something on the server, like the mysql server

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 4 semaines - il y a 1 mois 4 semaines #186979 par holch

The version is 2.73.0+171219. The installation is hosted by our university computing centre and I suspect there hasn't been an update for a long time :/


Yes, since the 19th of December 2017 to be exact... ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Dernière édition: il y a 1 mois 4 semaines par holch.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 semaines #187008 par molungus
Indeed there have been changes made to the myqsl server and the sysadmin reverted them. No everything works fine again.

I hope I'll see an update for LimeSurvey soon ;b

Thank you guys!
Les utilisateur(s) suivant ont remercié: LouisGac

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 semaines #187009 par LouisGac
I bet it was the "ONLY_FULL_GROUP_BY" parameter.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 3 semaines #187010 par cdorin
Hello Molungus, please get in touch with the IT team and recommend them to upgrade asap. As holch underlined above, that's quite an old version and it is a shame for students not to use the newest version of LimeSurvey. If they need help or have further questions, you may send them to us :) .

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!