Problems running installation script

Plus d'informations
il y a 1 semaine 11 heures - il y a 6 jours 6 heures #183309 par micaldas1
COM_KUNENA_MESSAGE_CREATED_NEW
HI,
I'm trying to install limesurvey3.17.1+190408.zip in a new Ubuntu 18.04 vps, with Apache and mysql.
I followed the steps in the installation manual but, when I accessed example.com/limesurvey/admin , I get this error message:
0) { define('YII_DEBUG', true); if($aSettings['config']['debug']>1) error_reporting(E_ALL); else error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED); } else { define('YII_DEBUG', false); error_reporting(0); } } else { error_reporting(E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED);// Not needed if user don't remove his 'debug'=>0, for application/config/config.php (Installation is OK with E_ALL) } if (version_compare(PHP_VERSION, '5.3.3', '<')) die ('This script can only be run on PHP version 5.3.3 or later! Your version: '.PHP_VERSION.'
'); require_once __DIR__ . '/third_party/autoload.php'; /* * -------------------------------------------------------------------- * LOAD THE BOOTSTRAP FILE * -------------------------------------------------------------------- * * And away we go... * */ require_once BASEPATH . 'yii' . EXT; require_once APPPATH . 'core/LSYii_Application' . EXT; $config = require_once(APPPATH . 'config/internal' . EXT); Yii::$enableIncludePath = false; Yii::createApplication('LSYii_Application', $config)->run(); /* End of file index.php */ /* Location: ./index.php */

I have absolutely no idea what this means although I read something about the php version and mine 7, so that musn't be the problem.

As I said, I have no idea what this means and any help would be greatly appreciated.

Thanks
Last edit: il y a 6 jours 6 heures by DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 6 jours 19 heures #183312 par jelo
COM_KUNENA_MESSAGE_REPLIED_NEW
That is an error but no error message. The php code is shown as source, which should not happen.
You should retry to complete installation. And if the same issue occurs, you will need to open a bug ticket.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Les utilisateur(s) suivant ont remercié: DenisChenu

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 jours 16 heures #183317 par holch
COM_KUNENA_MESSAGE_REPLIED_NEW
Are you sure your LAMP environment is setup correctly? You mention Apache and MySQL, what about PHP?

Looks like the PHP code isn't getting parsed.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 6 jours 6 heures #183320 par DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
before all :

help.ubuntu.com/community/ApacheMySQLPHP

and check with a phpinfo file

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!