Email not sent to new user

Plus d'informations
il y a 1 an 11 mois - il y a 1 an 11 mois #148510 par sherry721
sherry721 a créé le sujet : Email not sent to new user
I am currently trying to create a new user, but whenever I save the new users it only says that sending the email has failed.

Unfortunately there is no way to test the email settings in Limesurvey (send a test mail).

Is there a way I can find out what went wrong?

I saw other people's question to find out root cause, but it still failed.:(

Limesurvey Using Version 2.62.2+170203 on Ubuntu 16.04 server
Mail server using version Microsoft Exchange 2010

Below is my email settings at Global settings -> Email settings
Default site admin email: Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser.
Administrator name: sherry.lin
Email method: SMTP
SMTP host: tpmail.tpvaoc.com
SMTP username: sherry.lin
SMTP encryption: Off
SMTP debug mode: Off
Email batch size: 50


Limesurvey server didn't have below log after I occurred sent email failed.
/var/log/apache2/server-error.log
and
/var/log/apache2/mail.log





Pièces jointes :
Dernière édition: il y a 1 an 11 mois par sherry721.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #148525 par jelo
jelo a répondu au sujet : Email not sent to new user
Setting SMTP encryption off means you send your email credentials unencrypted through the internet.
Not the best thing when your company is listed in a stock exchange. A third party could get access to your email box.

First, you might try to use your complete emailadress as SMTP username.
But you should ask the admin of the exchange server if SMTP usage from outside is allowed.
This is not activated by default. So you might won't be able to send from LimeSurvey via Exchange without the help from your admin.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #148527 par holch
holch a répondu au sujet : Email not sent to new user
And why not try "SMTP debug mode" ON, this might give you some idea where the problem is.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #148676 par sherry721
sherry721 a répondu au sujet : Email not sent to new user
Hi Jelo,

Thanks for your reply, I will enable SMTP encryption.

The admin of exchange server gave relay permission to my account. (LimeSurvey server had installed Redmine system and Redmine can successfully use same emailaddress to send mail)

So, LimeSurvey should use same emailaddress to send via Exange.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #148677 par sherry721
sherry721 a répondu au sujet : Email not sent to new user
Hi holch,

It has same error message after I choose "Always" for "SMTP debug mode".

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 an 11 mois #148679 par sherry721
sherry721 a répondu au sujet : Email not sent to new user
I found weird situation.
If I used "Configuration"-->"Create/edit user groups"-->"Email user group", message sent successfully!
If I used "Configuration"-->"Manage survey administrators"-->"Add user", it will show "Email to XXXXX failed. And the top will show below error.

2017-02-15 06:19:14 CLIENT -> SERVER: QUIT 2017-02-15 06:19:14 SERVER -> CLIENT: 221 2.0.0 Service closing transmission channel

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 10 heures #178527 par hmd_bakhshi
hmd_bakhshi a répondu au sujet : Email not sent to new user
I have another odd problem.
I use default php mail in limesurvey. when a new user signup, it says that the password sent to his/her email. but no mail sent.
I try another way at login page by forgot password. after entering username and email, the system says that an email sent to you. but no email sent.
can any body help me in this problem?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 10 heures #178530 par holch
holch a répondu au sujet : Email not sent to new user
This is most probably a problem with php mail in general and your hosting environment. I would always recommend to use SMTP over the other methods. Because PHP mail is often already blocked on server level by your hosting company (to avoid spam or malware sending from this hosting account) or because the receiving email servers consider it as spam. PHP mail is not a good method. Go with SMTP.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 8 heures #178533 par hmd_bakhshi
hmd_bakhshi a répondu au sujet : Email not sent to new user
ok. I try using smtp with gmail account with these configs:\Email method: SMTP
SMTP host: smtp.gmail.com:587
SMTP username: Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser.
SMTP password: xxxxxxx
SMTP encryption: TLS

but it still doesn't work. when I try to retrieve my password it says sending email failed!

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 6 heures #178537 par holch
holch a répondu au sujet : Email not sent to new user
Well, at least you are a step ahead: Before it said it sent the email, but the email never arrived. So you don't know what happened. So it could have been because of spam filters, or a block from your provider, etc.

Now at least you know, that there was a problem sending the emails. Gmail is a little tricky when sending mass emails. You need to have very specific configurations for it to work. Try without encryption for now, just to identify if the problems is there somehow. And make sure that your credentials are correct, of course. ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 1 mois 6 heures #178538 par holch
holch a répondu au sujet : Email not sent to new user
You might want to check the other threads in the forum about how to get Gmail working for this, for example this one: www.limesurvey.org/forum/can-i-do-this-w...ey/107506-smtp-gmail

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 semaines 2 jours #178549 par hmd_bakhshi
hmd_bakhshi a répondu au sujet : Email not sent to new user
I check the page but it's not helpful.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 4 semaines 2 jours - il y a 4 semaines 2 jours #178564 par holch
holch a répondu au sujet : Email not sent to new user
So you tried this in Gmail?

Then I went to here: www.google.com/settings/security/lesssecureapps and changed the settng to ON.


I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Dernière édition: il y a 4 semaines 2 jours par holch.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 semaines 6 jours #178704 par hmd_bakhshi
hmd_bakhshi a répondu au sujet : Email not sent to new user
yes. I tried it, but doesn't solve my problem!

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 3 semaines 2 jours #178734 par holch
holch a répondu au sujet : Email not sent to new user
When it comes to problems with emails, experience here in the forum has shown, that the problem was mostly with the email server or the email settings. Otherwise we would have a lot of complaints here in the forum, if there was something wrong with the email functions of Limesurvey. So you will need to try with different email accounts (always go for SMTP) and see if one works, then check what is different with this email account than with the others. As we have no access to your server installation, there is very little we can do here in the forum, besides the hints we already gave.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!