Default answer value no longer works after upgrade

Plus d'informations
il y a 2 mois 3 semaines - il y a 2 mois 3 semaines #182837 par klaas
LimeSurvey
Version 3.15.5+181115

Hello!

I spent a lot of time browsing the forums and google but I could not find an answer to my problem (maybe I am googling the wrong things though!).

The idea is to have about 30 rows of 4 words. Participants have to give 4 points per row to the words that 'fit' them/their organisaition best. You can either give 1 word all the points or give multiple words some points (as long as the sum per row is 4).

My colleague (who no longer works with us) found a way to set the default answer to 0, because people usually divide their points to 2 words. (See screenshot) On Version 2.50+ Build 160425 this worked well. The questions were mandatory and people were forced to use their 4 points per row.

We recently upgraded limesurvey and the default 0 is no longer there. I tried uploading the lsg again but doesnt work. The questions still forces to give 4 points in total though. Its just the default 0 no longer appearing..


Possible solutions so far:

1. Keep mandatory questions and force people to type the 0 value manually if they give 0 points to that answer. However the survey consists of about 60 rows of 4 words. Im afraid a lot of people will give up halfway.

2. I could just make the question non-mandatory but then I wouldnt know if people fill in the survey correctly until its too late.

Anything I could do? I attached the lsg group.
Pièces jointes :
Dernière édition: il y a 2 mois 3 semaines par klaas.

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 2 mois 3 semaines #182848 par DenisChenu

klaas écrit: My colleague (who no longer works with us) found a way to set the default answer to 0,

I know 2 way to do so :
1.JavaScript way (set value to 0 if it's "") : if the script is still here : deactivate ajax mode to get it work again (deactivate ajax mode globally is the best solution)

2. Equation question set : search if you havbe a equation question type doing something like that before the array question.

klaas écrit: …
2. I could just make the question non-mandatory but then I wouldnt know if people fill in the survey correctly until its too late.

If you force each line to sum to 4 : user must answer something, then no issue with that.

klaas écrit: Anything I could do? I attached the lsg group.

Please : only a lss … with only this question.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!