Displaying Emojis from imported files

Plus d'informations
il y a 8 mois 1 semaine #179194 par ferdeng
Dear all,

I have the following problem.

I exported my survey as txt, edited it and imported it again. Everything works great.

The only thing that doesn't work are emojis.
For example, my imported txt contains a grinning Emoji. I saved the txt encoded survey to be imported as UTF-8. Everything works after the import process, except for the emoji which is displayed as ????.

I also tried adding "<meta charset="UTF-8">" at the beginning of the question as a code, but that didn't change anything. Strangely, when I manually edit the question in LS and just paste the emoji, it's displayed correctly. So it seems that LS can display emojis, the problem must be with the import process.

How can I fix this?

Thanks in advance!

Connexion ou Créer un compte pour participer à la conversation.

LimeSurvey Partners
Plus d'informations
il y a 8 mois 1 semaine #179217 par DenisChenu
I'm sure you use excel, this is a broken tool : use LibreOffice calc : www.libreoffice.org/download/download/

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
Les utilisateur(s) suivant ont remercié: LouisGac

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 1 semaine #179218 par ferdeng
Dear Denis,

thanks for your reply. Indeed, I first tried to do this with excel, but I didn't even manage to import one single question. That's why I already did everything in libre office. But don't get me wrong, the Emoji is also correctly display in Libre (as a Emoji, not as a codepoint). And even in the txt when I open it with the editor (still as the real emoji).

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 6 jours #179233 par DenisChenu
But then : where it'sdiplay has not an emoji ?

I check myself : seems OK

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 6 jours #179239 par ferdeng
If it do it manually (by that I mean editing a question in Limesurvey directly), it works, yes.
If I import my survey from a txt document (and exported survey I manipulated to add more questions), everything except for the emojis works. I only get to see ???? instead of the emoji. I tried both encoding as ASCII and UFT 8.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 6 jours - il y a 8 mois 6 jours #179240 par DenisChenu
When is say i check i
- Export as TSV
- Update with LibreOffice
- Save as TSV (UTF8, tab separator)
- Import

And it's OK

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
Dernière édition: il y a 8 mois 6 jours par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 6 jours #179241 par ferdeng
So you exported as TSV, edited the question (added an emoji) with Libre, saved as txt again, imported and it's working?

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 6 jours #179269 par ferdeng
Even tried the following thing now: I imported the manipulated survey with emojis, they're not shown (only ????). They I exported this version again, edited with libre office (replaced ???? with the emoji), imported again to Limesurvey. But still, it's only displayed as ???? again.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 5 jours - il y a 8 mois 5 jours #179281 par DenisChenu

ferdeng écrit: So you exported as TSV, edited the question (added an emoji) with Libre, saved as txt again, imported and it's working?

Yes



I add another emoji, save as utf8 : and it's OK



PS : another idea : linux rules !

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
Pièces jointes :
Dernière édition: il y a 8 mois 5 jours par DenisChenu.

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 5 jours #179324 par ferdeng
Thanks for trying this! Are they also displayed correctly when you store them inse a question? And if you test the survey? I don't know what I could do differently...

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 4 jours #179333 par DenisChenu
Yes

Can you send me a sample (not working) tsv file ?
Here is mine

Fichier attaché :

Nom du fichier : limesurvey...3731.zip
Taille du ficher :3 ko

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 4 jours #179362 par ferdeng
Of course!
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Plus d'informations
il y a 8 mois 4 jours #179369 par DenisChenu
It's OK on my 2 server … (5.6 and 7.2 / linux)


Maybe related to server … maybe try to report the issue with all information

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
Pièces jointes :

Connexion ou Créer un compte pour participer à la conversation.

Commencez dès maintenant !

Créez simplement un compte et commencez à utiliser LimeSurvey dès aujourd'hui.

Inscrivez-vous maintenant

Inscrivez-vous à notre Newsletter!